saint158
?>

100 . напишите программу на паскале. шестое и ягоды шли как-то два по лесу и собирали ягоды. час шли, два шли, а потом вдруг остановились и решили помериться. достали они весы (какой же пойдет в лес без весов? ) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a1 и b1 на листочек. после этого второй пересыпал все ягоды в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a2 и b2 соответственно. наконец, первый пересыпал все ягоды в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a3 и b3 соответственно. этих данных оказалось достаточно для определения победителя, и довольные пошли дальше. вам же предстоит вычислить массу ягод в корзине каждого из до совершения всех пересыпаний. формат входных данных входные данные состоят из трёх строк. в i-й строке (1 ≤ i ≤ 3) записаны целые числа ai и bi (0 ≤ ai, bi ≤ 10 000 формат результата в единственной строке выведите пару целых чисел через пробел — сколько ягод собрали, соответственно, первый и второй . примеры входные данные 1 2 2 1 0 3 результат работы 1 1

Информатика

Ответы

pechinin

Пусть массы корзин k1 k2, ягод - y1 y2

Тогда

k1+y1=a1

k2+y2=b1

k1+y1+y2=a2

k2=b2

k1=a3

k2+y1+y2=b3

Как видишь, математики - полные лохи, количество данных даже избыточно. Возьмем только

y1=a1-a3

y2=b1-b2

Теперь осталось сравнить 2 полученных числа.

dushechkin2
 --- gfortran 6.3 ---
program prog1
integer N, k, i, j
real a(10,10)
read *, N
print *, 'Матрица:'
do i = 1,N
 do j = 1,N
   a(i,j) = sin(1.0*i+1.0*j/2)
 end do
end do
do i = 1, N
 print *, (a(i,j), j=1,N)
end do
k = 0
do i = 1, N
 do j = 1, N
  if(a(i, j) > 0) k = k+1
 end do
end do 
print *, k
end

Результат:
4
Матрица:
   0.997494996 0.909297407 0.598472118 0.141120002
   0.598472118 0.141120002 -0.350783229 -0.756802499
  -0.350783229 -0.756802499 -0.977530122 -0.958924294
  -0.977530122 -0.958924294 -0.705540299 -0.279415488
      6
ekatef45
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

procedure Cheburek(s:string);
begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в массиве:');
  Writeln('*** ',s,' матрица [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var s1:='сортированный вектор ср.значений нечетных столбцов';
  Writeln(s1);
  a.Cols.Select(x->x.Average).Where((x,i)->i.IsEven).Sorted.Println;
  Writeln(s1.Length*'-');
end;

begin
  Cheburek('первая');
  Cheburek('вторая');
end.

Пример
Количество строк в матрице: 4
Количество столбцов в массиве: 8
*** первая матрица [4,8] ***
  98 -64 -30  84  -6  11   4   7
 -45  23  55  47  67  87  70 -64
  40  20  91 -27 -12  42 -49  10
 -59 -79   5 -77 -59 -44  -4 -10

сортированный вектор ср.значений нечетных столбцов
-2.5 5.25 8.5 30.25

Количество строк в матрице: 6
Количество столбцов в массиве: 11
*** вторая матрица [6,11] ***
 -98 -40 -42  81  39  28  -3 -24 -33  79  13
  22  26 -79  90  93  46  94  83  -1 -13 -18
 -21 -44  85  60  43 -26 -94 -19 -34  99 -72
 -35  46   8  30  88  -4 -87 -76  15 -94   9
 -70  29  83 -79 -69  12 -24 -53 -27  96 -97
  19  80 -98  96  79  84 -76 -29  85  14  14

сортированный вектор ср.значений нечетных столбцов
-31.6666666666667 -30.5 -25.1666666666667 -7.16666666666667 0.833333333333333 45.5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

100 . напишите программу на паскале. шестое и ягоды шли как-то два по лесу и собирали ягоды. час шли, два шли, а потом вдруг остановились и решили помериться. достали они весы (какой же пойдет в лес без весов? ) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a1 и b1 на листочек. после этого второй пересыпал все ягоды в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a2 и b2 соответственно. наконец, первый пересыпал все ягоды в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a3 и b3 соответственно. этих данных оказалось достаточно для определения победителя, и довольные пошли дальше. вам же предстоит вычислить массу ягод в корзине каждого из до совершения всех пересыпаний. формат входных данных входные данные состоят из трёх строк. в i-й строке (1 ≤ i ≤ 3) записаны целые числа ai и bi (0 ≤ ai, bi ≤ 10 000 формат результата в единственной строке выведите пару целых чисел через пробел — сколько ягод собрали, соответственно, первый и второй . примеры входные данные 1 2 2 1 0 3 результат работы 1 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmitryshigin
Koshovkina1721
matoksana
koxhulya61
best00
vdm4275
zverevahelen
shangina1997507
Nadirovich1317
Александрович Владимирович
toxicfish
yliana
bandurinei
yusliva
rayman777