generallor3
?>

Написать программу, в которой при каких-то (придумать самим) действиях пользователя будут возникать и обрабатываться исключения: dividebyzeroexception, formatexception, indexoutofrangeexception, overflowexception, stackoverflowexception.

Информатика

Ответы

Евгения-Валерий

===== PascalABC.NET =====

begin

 var a := ReadlnInteger('Введите целое число:');

 try

   Println(1 div a);

 except

   on System.DivideByZeroException do

     Println('Попытка деления на ноль');

 end;

 try

   var s := ReadlnString('Введите число с дробной частью:');

   s.ToReal.Println;

 except

   on System.FormatException do

     Println('Неверная запись вещественного числа')

 end;

 var b := ArrRandom(5, -10, 10);

 try

   Println(b[ReadlnInteger('Какой элемент массива вывести?')])

 except

   on System.IndexOutOfRangeException do

     Println('Неверный индекс')

 end;    

 try

   BigInteger.Parse(ReadlnString('Введите число:')).ToString.ToInteger

 except

   on System.OverflowException do

     Println('Слишком большое число')

 end

end.

Примечание: StackOverflowException невозможно перехватить в версии .NET выше 2.0.


Написать программу, в которой при каких-то (придумать самим) действиях пользователя будут возникать
Vrezh
MS DOS
Операционная система MS DOS (Microsoft Disk Operating System) – самая распространённая ОС на 16-разрядных персональных компьютерах, состоит из следующих модулей:базовой системы ввода/вывода (BIOS);блока начальной загрузки (Boot Record);модуля расширения базовой системы ввода/вывода (Io.SYS);модуля обработки прерываний (MsDos.SYS);командного процессора (Command.COM);утилит MS DOS.Каждый из указанных модулей выполняет определённую часть функций, возложенных на ОС. Места постоянного размещения этих модулей различны. Так, базовая система ввода/вывода находится в постоянном запоминающем устройстве (ПЗУ), а не на дисках как все остальные модули. Windows 1.0 Когда фирма Microsoft созвала пресс-конференцию на выставке Comdex, проходившей в ноябре 1985 года в Лас-Вегасе, многие посчитали это событие последним шансом, особенно после того как среда Windows не была выпущена, как было обещано, в июне того же года. Пресс-конференция плавно перетекла в презентацию нового продукта - Microsoft Windows 1.0. Windows95 Windows 95 представляет собой универсальную высокопроизводительную многозадачную и многопотоковую 32-разрядную ОС нового поколения с графическим интерфейсом и расширенными сетевыми возможностями. Windows 95 – интегрированная среда, обеспечивающая эффективный обмен информацией между отдельными программами и предоставляющая пользователю широкие возможности работы с мультимедиа, обработки текстовой, графической, звуковой и видео информации. Интегрированность подразумевает также совместное использование ресурсов компьютера всеми программами. Применяемый в Windows 95 защищённый режим не позволяет прикладной программе в случае сбоя нарушить работо системы, надёжно предохраняет приложения от случайного вмешательства одного процесса в другой, обеспечивает определённую устойчивость к вирусам. Пользовательский интерфейс Windows 95 прост и удобен. В отличие от оболочки Windows 3 эта операционная система не нуждается в установке на компьютере операционной системы DOS. Она предназначена для установки на настольный ПК и компьютерах блокнотного типа с процессором 486 или Pentium. Рекомендуемый размер оперативной памяти (ОЗУ) 8-32 Мбойт. После включения компьютера и выполнения программ BIOS операционная система Windows 95 автоматически загружается с жёсткого диска. После загрузки и инициализации системы на экране появляется рабочий стол, на котором размещены различные графические объекты. Пользовательский интерфейс спроектирован так, чтобы максимально облегчить усвоение этой операционной системы новичками и создать комфортные условия для пользователя.
Moroshkina-Aristova2011
1. Ну я не знаю какая часть фигуры закрашена. Будем считать что прямоугольник находиться в окружности и необходимо из площади курга вычесть площадь прямоугольника.
const
p =3.14;
var
a,b,r,s1,s2:real;
begin
Writeln('Введите длины сторон прямоугольника');
readln(a,b);
Writeln('Введите радиус окуржности');
Readln(r);
s1:=a*b;
s2:=p*sqr(r);
Writeln('Площадь закрашеной окружности = ', s2-s1);
end.

Если закрашена какая-то другая область то можете просто изменить действие с площадями в предпоследней строчке ( в данном случае мы из s2 вычитаем s1).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, в которой при каких-то (придумать самим) действиях пользователя будут возникать и обрабатываться исключения: dividebyzeroexception, formatexception, indexoutofrangeexception, overflowexception, stackoverflowexception.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tihonovrv477
Баринова
miumiumeaow
stomcom01
Talikova164
tribunskavictory
marinakmaa86
Maksimova1320
Александровна-Васильевна
Напишите программу в Паскаль:
meu72
gullieta
Смирнов-Оськина
armynis8
slastena69678
farmprofi
▲