EVLAMPIN56
?>

Написать программу оптимизации двоичного кода, которая сжимает серии повторяющихся цифр, формируя массив из количеств элементов. при этом множество единиц или нулей формируют новый массив. например серия [0, 0, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 0, 1, 1, 1, 1] преобразуется в [4, 7, 2, 4] - массив начинается с 0, и серия [1, 1, 1, 0, 0, 0, 0, 0, 0, 0] формируется в [0, 3, 7] - т.к. массив начинается с 1, что означает, что есть нулевой 0 в начале массива.

Информатика

Ответы

Евгения-Валерий

Program pr1;

uses crt;

var  

  n:byte; // Размерность массива

  i:byte; // Счетчик массива

  a:array[1..20] of real; // Массива чисел

  S:real; // Сумма чисел

Begin

  clrscr;

  write('Введите размерность массива: ');

  readln(n);

  writeln('Введите ',n,' элементов');

// Блок ввода

  for i:=1 to n do

     readln(a[i]);

// Блок вывода

  writeln('Исходный массив');

  for i:=1 to n do

     write(a[i]:6:1,' ');

     writeln;

     readln;

// Блок инициализации

  S:=0;

  for i:=1 to n do

     if(a[i]<5) then

        S:=S+a[i];    

  readln;

  writeln('S= ',S);

End.

utkinslava

Program pr1;

uses crt;

var  

  n:byte; // Размерность массива

  i:byte; // Счетчик массива

  a:array[1..20] of real; // Массива чисел

  S:real; // Сумма чисел

Begin

  clrscr;

  write('Введите размерность массива: ');

  readln(n);

  writeln('Введите ',n,' элементов');

// Блок ввода

  for i:=1 to n do

     readln(a[i]);

// Блок вывода

  writeln('Исходный массив');

  for i:=1 to n do

     write(a[i]:6:1,' ');

     writeln;

     readln;

// Блок инициализации

  S:=0;

  for i:=1 to n do

     if(a[i]<5) then

        S:=S+a[i];    

  readln;

  writeln('S= ',S);

End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу оптимизации двоичного кода, которая сжимает серии повторяющихся цифр, формируя массив из количеств элементов. при этом множество единиц или нулей формируют новый массив. например серия [0, 0, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 0, 1, 1, 1, 1] преобразуется в [4, 7, 2, 4] - массив начинается с 0, и серия [1, 1, 1, 0, 0, 0, 0, 0, 0, 0] формируется в [0, 3, 7] - т.к. массив начинается с 1, что означает, что есть нулевой 0 в начале массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zbellatriks
elenak26038778
arionul-secondary2
Stanislavovna1237
Вячеславович-Дмитрий1694
artashhovhan
Aleksandrovich_Mitoyan1138
JisesLove19955
ghjcnjtyjn64
Gesper63
tenvalerij
vallod
Спиридонова
dkedrin74038
alfastore4