Вакуленко
?>

C++ написать программу ! do while для новичков ! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. необходимо определить, равны ли между собой все элементы последовательности. отрицательное число членом последовательности не является. формат выходных данных выведите «yes», если условие выполняется, и «no» в противном случае. 1 no 2 3 4 5 -1

Информатика

Ответы

CafedeMinou

#include <iostream>

using namespace std;

int main () {

   int n;

   cin >> n;

   if (n==0) {

       cout << "0  0" << endl << 1 << endl << 1 << endl;

       return 0;

   }

   int mx=0; int mn=10; int mxi=10; int mnk=0; int ind=0;

   while (n>0) {

       int c=n%10;

       n/=10;

       if (c>=mx) {

           mx=c;

           mxi=ind;

       }

       if (c<mn) {

           mn=c;

           mnk=1;

       } else if (c==mn) ++mnk;

       ++ind;

   }

   cout << mx << " " << mn << endl << (ind - mxi) << endl << mnk << endl;

   return 0;

}

Объяснение:

darialyagina
Const n=4; m=5;
var a:array [1..n,1..m] of integer;
 i,j,min,imin,jmin:integer;
begin
Randomize;
Writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do begin
 a[i,j]:=random(21)-10;
 write(a[i,j]:6);
 end;
writeln;
end;
min:=a[1,1]; imin:=1;jmin:=1;
for i:=1 to n do
 for j:=1 to m do
  if a[i,j]<min then
   begin min:=a[i,j]; imin:=i; jmin:=j; end;
writeln('min=a[',imin,',',jmin,']=',min);
end.

Пример:
Исходный массив:
     5     8     2    -5    -4
     1   -10     9     1    -4
     8     2    -6    -4    -4
     8     7     3     2     2
min=a[2,2]=-10
Olia72

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ написать программу ! do while для новичков ! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. необходимо определить, равны ли между собой все элементы последовательности. отрицательное число членом последовательности не является. формат выходных данных выведите «yes», если условие выполняется, и «no» в противном случае. 1 no 2 3 4 5 -1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

volkovaekaterina303
egorsalnikov1997139
Pastel-sova
saryba
makashi28
Качкова1820
МАМОНОВА-андрей
zhmulyov-denis8
bykotatyana
kate1610
zodgener
zamkova836
Эрендженова
Volkovapavel