nsoro937
?>

Решите ( желательно питон или просто разъяснить алгоритм) играют двое. задаётся какая-то дата 2020 года. каждый игрок на своём ходе называет более позднюю дату, увеличивая на 1 или 2 либо день в месяце, либо месяц, но не то и другое сразу. при этом сочетание дня и месяца должно оставаться датой. игрок, назвавший 31 декабря, проигрывает. оба играют наилучшим образом. исходя из заданной даты вывести, кто выиграет. входные данные в первой строке находятся числа, обозначающие день и месяц. выходные данные вывести 1, если выигрывает первый (начинающий) игрок, или 2 - в противном случае. экзампл : входные данные 30 12 выходные данные 2

Информатика

Ответы

Nataliatkachenko1
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    const int N=7;
    int A[N];
    cout << "Введите массив, состоящий из " << N << " элементов:\n";
    for (int i=0; i<N; i++)
        cin >> A[i];
    cout << "Массив до - ";
    for (int i=0; i<N; i++)
    {
        cout << A[i] << " ";
        if (A[i]*A[i] < 25) A[i] *= 2;
    }
    cout << "\nМассив после - ";
    for (int i=0; i<N; i++)
        cout << A[i] << " ";
    _getch();
    return 0;
}

Microsft Visual C++ 2010
v-zhigulin1
/*задача дурацкая для n > 3, ибо не понятно, что делать:
1) разбить все столбцы на группы одинаковых столбцов и посчитать внутри них число пар. Затем суммировать.
2) разбить столбцы на группы одинаковых столбцов и суммировать количество элементов в каждой из групп, если оно больше 1. То есть найти количество столбцов, для которых среди других столбцов найдется хотя бы один идентичный ему
3) разбить столбцы на группы одинаковых столбцов и вывести количество элементов в каждой группе, если оно больше 1.
Для n=3 дело проще, потому что таких групп максимум одна, поэтому тут, по сути, неоднозначности не возникает (за исключением того, что в первом пункте...)
В общем, решил делать как во втором пункте. ответ в любом случае будет верным.*/
#include <iostream>
using namespace std;
int n, result = 0;
int **ar;//указатель на указатель для создания динамического двумерного массива
bool *Flag;//указатель на первый элемент массива флагов
void create(int n)//создание динамического массива
{
   ar = new int*[n];
   for (int i = 0; i < n; i++)
      ar[i] = new int[n];
   Flag = new bool[n];
   for (int i = 0; i < n; i++)
      Flag[i] = false;
}
void inp(int n) //ввод элементов массива
{
   cout << "Input rows of matrix:\n";
   for (int i = 0; i < n; i++)
   {
      cout << i + 1 << ": ";
      for (int j = 0; j < n; j++)
         cin >> ar[i][j];
   }
}
void outp(int n) //вывод элементов массива
{
   cout << "Elements of matrix:\n";
   for (int i = 0; i < n; i++)
   {
      for (int j = 0; j < n; j++)
         cout << ar[i][j] << " ";
      cout << endl;
   }
}
bool isEqual(int n, int j1, int j2)//проверка на равенство столбцов
{
   bool res = true;
   for (int i = 0; i < n; i++)
   {
      if (ar[i][j1] != ar[i][j2])
      {
         res = false;
         break;
      }
   }
   if (res)//если столбцы равны
    Flag[j2] = true; /*отмечаем столбец как просмотренный, чтобы в следующий раз его не сравнивать с другими столбцами*/
   return res;
}
void calculate(int n)//считаем количество совпадающих столбцов
{
   int k = 1;
   for (int j1 = 0; j1 < n; j1++)
    if (!Flag[j1])
    {
      k = 1;
      for (int j2 = j1 + 1; j2 < n; j2++)
       if (!Flag[j2] && isEqual(n, j1, j2))
          k++;
      if (k > 1)//имеется k одинаковых стобцов по типу столбца j1
         result += k;//плюсует к итоговому результату
    }
}
int main(){
   cout << "Input n: ";
   cin >> n;
   create(n);
   inp(n);//ввод массива
   outp(n);//вывод массива
   calculate(n);//расчет того, что требуется
   if (result > 0)/*количество столбцов, которые совпадают, по крайней мере, с одним из других столбцов*/
      cout << "The number of columns, coinciding with at least one other column, is " << result << endl;
   else //все столбцы разные
      cout << "There is no matching columns\n";
   return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите ( желательно питон или просто разъяснить алгоритм) играют двое. задаётся какая-то дата 2020 года. каждый игрок на своём ходе называет более позднюю дату, увеличивая на 1 или 2 либо день в месяце, либо месяц, но не то и другое сразу. при этом сочетание дня и месяца должно оставаться датой. игрок, назвавший 31 декабря, проигрывает. оба играют наилучшим образом. исходя из заданной даты вывести, кто выиграет. входные данные в первой строке находятся числа, обозначающие день и месяц. выходные данные вывести 1, если выигрывает первый (начинающий) игрок, или 2 - в противном случае. экзампл : входные данные 30 12 выходные данные 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gennadevna
abdulhakovalily22
rynaodal
Natakarpova75732
Valerevna-Vardan
Nataliya Aleksandr1197
spikahome
тахирович_Игорь581
maxchuev
terehin863
sve-lysenko
Vuka91
alexkortyukov
kengyra
randat887040