osechkinandrejj
?>

Описать структуру с именем aeroflot, содержащую следующие поля: • название пункта назначения рейса; • номер рейса; • тип самолета. написать программу, выполняющую следующие действия: 1. ввод с клавиатуры данных в массив, состоящий из семи элементов типа aeroflot, записи должны быть размещены в алфавитном порядке по названиям пунктов назначения; 2. вывод на экран пунктов назначения и номеров рейсов, обслуживаемых самолетом, тип которого введен с клавиатуры; 3. если таких рейсов нет, выдать на дисплей соответствующее сообщение.

Информатика

Ответы

motor2218
На этот раз вроде бы и не торопился, все просмотрел (но наверняка, как всегда что-нибудь просмотрел)))), и кажется мне, что "школьное" решение уважаемого Эникея не удовлетворяет поставленной задаче (боюсь, что опять придется извиняться, но все же рискну).
Из массива не удалены все отрицательные элементы. Их не видно, потому что распечатывается не весь массив. На первом скане видно, что при вводе массива (-1,-2,3,4,-5) элементы 4 и -5 остались на своих местах, просто они не выводятся на печать. Вот поэтому я считаю, что это решение некорректно, поставленная задача не выполнена.
Свой вариант решения привожу на втором скане.
Паскаль авс.net . дано одномерный массив длиной n. сжать его , изъяв все отрицательные элементы.
Паскаль авс.net . дано одномерный массив длиной n. сжать его , изъяв все отрицательные элементы.
Иванов1813
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите',ReadInteger('n='));
  a:=a.Where(x->x>=0).ToArray; a.Println
end.

Пример
n= 5
Вводите 3 -2 0 -1 5 8
3 0 5

То же, в терминах Pascal ABC ("по-школьному")

const
  k=50;
var
  n,i,m:integer;
  a,t:array[1..k] of integer;
begin
  Write('n='); Read(n);
  Write('Вводите: ');
  for i:=1 to n do Read(a[i]);
  m:=0;
  for i:=1 to n do
    if a[i]>=0 then begin
      m:=m+1;
      t[m]:=a[i]
      end;
  n:=m;
  for i:=1 to n do begin
    a[i]:=t[i];
    Write(a[i],' ')
    end;
  Writeln
end.

Думаю, есть о чем подумать: почему в школе учат писать длинно и сложно?

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Описать структуру с именем aeroflot, содержащую следующие поля: • название пункта назначения рейса; • номер рейса; • тип самолета. написать программу, выполняющую следующие действия: 1. ввод с клавиатуры данных в массив, состоящий из семи элементов типа aeroflot, записи должны быть размещены в алфавитном порядке по названиям пунктов назначения; 2. вывод на экран пунктов назначения и номеров рейсов, обслуживаемых самолетом, тип которого введен с клавиатуры; 3. если таких рейсов нет, выдать на дисплей соответствующее сообщение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

геннадиевна2001
slitex
srgymakarov
Chistov9721209
Natakarpova75732
superniki87
Nataliya Aleksandr1197
Gennadievna bessonov
Rafigovich1267
ЮлияДаниил520
maxkuskov2485
askorikova
gilmore886173
mberberoglu17
Shishkinna2002