tatk00
?>

Pascal три друга пообедали в ресторане. официант подал им счет на х, y, z рублей каждому (х, y, z - случайные числа от 100 до 1000 друзья решают оставить официанту чаевые в размере 10% от каждого счета. составьте программу, которая выведет на экран сумму чаевых, которую получил официант, а также слова «большое », если чаевых больше 100 рублей и «приходите к нам еще! », если чаевых меньше 100 р.

Информатика

Ответы

ekaterinasamoylova4705
Import java.util.*; import java.lang.*; import java.io.*; class MyLab { public static void main (String[] args) { int a; //первое число, от которого начнем int b; //второе число, до которого будем считать произведение int product; //произведение всех целых чисел Scanner in; //с этого объекта читаем ввод с клавиатуры in = new Scanner(System.in); System.out.println("Enter A: "); a = in.nextInt(); System.out.println("Enter B: "); b = in.nextInt(); if (a > b) //если число от которого начинаем больше чем до которого нужно считать - поменять их местами { int buf = a; //сохраняем значение a a = b; //присваиваем переменной a значение переменной b b = buf; //присваиваем переменной b значение сохраненной в buf переменной a } product = 1; //инициализируем 1, что бы получить корректное произведение (ни в коем случаи не 0м, если вы не понимаете почему именно 1, то вам нечего делать в программировании, без обид) for (int i = a; i <= b; ++i) //цикл, повторяем на промежутке от a до b с шагом в 1 { product *= i; //умнажаем текущее значение произведения всех целых чисел на текущее целое число } System.out.printf("Product of all integer numbers from A = %d, to B = %d, is = %d\n", a, b, product); } }
eremenkou
В сообщении 16+8+4+4=32 символа. Вероятность появления символа А равна 16/32=1/2, символа Б 8/32=1/4, символов В и Г - 1/8.
Следовательно, для минимизации длины сообщения (условие "б") самым коротким должен быть символ А, несколько длиннее может быть символ Б и самые длинные - символы В и Г. По этой причине вариант 4) с равной длиной кодов не рассматриваем. Далее, достаточно компактными выглядят коды в варианте  2), но А=0 и В=01 нарушают условие "а" (код 0 является началом кода 01). Остаются варианты 1) и 3)
В варианте 1) нарушений условий нет. В варианте 3) код буквы Б 01 является началом кода буквы В 011 и это нарушает условие "а".
ответ: 1)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal три друга пообедали в ресторане. официант подал им счет на х, y, z рублей каждому (х, y, z - случайные числа от 100 до 1000 друзья решают оставить официанту чаевые в размере 10% от каждого счета. составьте программу, которая выведет на экран сумму чаевых, которую получил официант, а также слова «большое », если чаевых больше 100 рублей и «приходите к нам еще! », если чаевых меньше 100 р.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vsnimschikov391
kirik197308
yatania-popovich7
centrprof20
Грачева мураховская
Vyacheslav_Nikolaevna
kep92
nailya-abdulova25
is0019
diana-020
Валуева
jnrhjq3597
ver2bit29
av4738046
Белов_Лукина1339
▲