Anastasiya Yevseeva948
?>

составьте программу, которая вычисляет периметр треугольника со сторонами a, b, c и выводит результат на экран.в pascal abc

Информатика

Ответы

mvolkov8

var a,b,c:integer;

Begin

read(a,b,c);

write(a+b+c);

end.

Андреевич-Екатерина1974
Program Test;

Var
a1, a2, d, k, max, tmp: integer;
sum: real;
rule: boolean;

Begin

Writeln('Введите а1 и а2');
Readl(a1, a2);

k := 2;
d := a2 - a1;
rule := true;

while (rule = true) do
begin
k := k + 1;
tmp := a1 + k * d;

if (tmp < 50) then
max := tmp

else
rule := false;

end;

sum := (a1 + max) / 2 * k;

Writeln();
Writeln('Сумма = ', sum);

End.


Программа будет работать только для арифметических прогрессий, например, таких, как последовательность из задания. Вводить нужно 2 целых числа (первые два члена прогрессии) через пробел (в вашем случае 4 и 7)
MArat
Const
  n=7;

type
  V=array[1..n] of real;

var
  P:V;
  i,k:integer;
  a,b,c,d:real;

begin
  Writeln('Вводите длины сторон четырехугольника через пробел');
  for i:=1 to n do begin
    Write(i,': '); Read(a,b,c,d);
    P[i]:=a+b+c+d;
    end;
  k:=0;
  for i:=n-1 downto 1 do
    if P[i]=P[n] then k:=k+1;
  Writeln('Четырехугольников с периметром, как у последнего: ',k)
end.

Пример
Вводите длины сторон четырехугольника через пробел
1: 5 7 3 8
2: 3 7 3 6
3: 5 8 5 2
4: 6 8 4 1.9
5: 8 3 5 9
6: 7 3 7 2
7: 5 5 5 4
Четырехугольников с периметром, как у последнего: 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составьте программу, которая вычисляет периметр треугольника со сторонами a, b, c и выводит результат на экран.в pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

thebest59
asparinapti39
irinatikhonov
Shishkinna2002
lenalevmax7937
ilyanedelev
Tane4ka2110
elmiro4ka868617
vdk81816778
fellybrossme
M19026789436
Джулия
sbelova
prostopo4ta29
Vyacheslavovich-Gubanov
▲