var a, b, с: integer;
begin
write('Введите два числа: ');
readln(a, b);
if a < b then с := a + 1 else с := b + 1;
repeat с := с - 1
until (a mod с = 0) and (b mod с = 0);
write('NOD = ', с)
end.
//2. Алгоритм с вычитанием (цикл while)
var a, b: integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
while a <> b do
if a > b then
a := a - b
else
b := b - a;
writeln('NOD = ', a);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Составить: программу на языке паскаль. ! 30 . 2 ! просто написать программу на языке паскаль 1) заполните одномерный массив из 15 элементов числами от -15 до 15 и выведите на экран сумму всех его отрицательных элементов. 2) для целочисленного массива a[1: 15] определите, является ли сумма его элементов четным числом. выведите на печать “да” или “нет”.
PascalABC.NET
#1
begin
var A := ArrRandom(15, -15, 15).Where(x -> x < 0).Sum.Println;
end.
#2
//Под A[1:15] я понял индексы элементов.
begin
var A := ArrRandom(15, -100, 100);
if A.Sum mod 2 = 0 then Println('ДА')
else Println('НЕТ');
end.