ykolkova76
?>

Напишите программу которая находит первые n натуральных чисел у которых остаток от деления на 3 равен 1. pascalabc.net

Информатика

Ответы

vahmistrova

var n, a: integer;

begin

   readln(n);

   for a:=1 to n * 3 do if a mod 3 = 1 then writeln(a)

end.

Оздоевский

===== PascalABC.NET =====

begin

 SeqGen(ReadInteger, 1, p -> p + 3).Print

end.


Напишите программу которая находит первые n натуральных чисел у которых остаток от деления на 3 раве
happych551
Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся из файла Input.txt. Результаты работы программы записываются в файл Out.txt. 
Вопрос в том что я написал программу: и вывел чтоб он считал сумму четных чисел а сумму считает не правильно 

вот программа: 

//
#include <stdio.h> 
#include <conio.h> 
#include <math.h> 
//
int main () 

FILE *f1, *f2; 
int n, i; 
float s; 
f1 = fopen("input.txt", "r"); 
f2 = fopen("out.txt", "w"); 
fscanf (f1, "%d", &n); 
for (i=1; i<=n; i++) 

if ((n>0) && (i%2==0)) 
fprintf(f2, "=", i); 

s=0; 

s=(float)s+i; 
fprintf(f2,"\n Summa=%f", s); 

fclose(f1); 
fclose(f2); 
getch(); 
return 0; 

//
Дополнен 2 года назадв общем то я понял то что сумму он считает так то что впишу в файл к примеру 5 он к этому числу просто прибавляет 1 и все а мне нужно чтоб он считал все четные числа которые вывелись к примеру написал 6 он должен сложить 2+4+6 будет 12 а он пока делает я ввел 6 к нему 6+1 и 7 типаДополнен 2 года назадвот программа в паскале 
както так
zazaza74
Ну почему,когда просят написать программу никто никогда не указывает язык программирования.я напишу на языке паскаль с входным и выходным файлом,но если это не тот язык,твоя проблема.(сообщения в фигурных скобках,это комментарии,просто для пояснение,можешь удалить их)

program p1;
const n=10;
var a : array[1..n] of integer;
i,b,c:integer;
begin 
randomize; 
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);

for i:=1 to n do {Заполнение исходного массива}   
a[i]:=random(21)-10;
  
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)}
write(a[i]:4);

c:=0; {Инверсия массива} 
for i:=1 to 2 do  begin   
b:=a[i];   
a[i]:=a[5-c];   
a[5-c]:=b;   
c:=c+1; 
end; 
c:=0; 
for i:=6 to 8 do 
begin   
b:=a[i];   
a[i]:=a[10-c];   
a[10-c]:=b;   
c:=c+1; 
end; 
writeln;
  
for i:=1 to n do {Вывод инверсированого массива} 
write(a[i]:4);

close(input);
close(output);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая находит первые n натуральных чисел у которых остаток от деления на 3 равен 1. pascalabc.net
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chervonnaya-Aleksei
andruhovich
olga0909196323
tyrnaus
Fruktova Gazaryan
Kateshaeva
rytikovabs
lider-mpl550
Bobkov
Dms161964937
Nastyaches4
vintazhvintazh90
vs617
n-896458
mansur071199486