Gennadievna bessonov
?>

Составить программу, которая будет считывать введённое десятизначное число. после чего, каждую цифру этого числа необходимо вывести в новой строке. использовать нужно арифметические операции с целыми и вещественными числами. на python.

Информатика

Ответы

Иванов

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;
akustov55

from builtins import print

a = int(input())

b = int(input())

c = int(input())

d = int(input())

if (a + b + c + d) == (a * b * c * d):

  print('Сумма и произведения равны')

else:

  if (a + b + c + d) < (a * b * c * d):

      print('Cумма меньше произведения')

  else:

      print('Сумма больше произведения')

#2

sum = 0

for i in range(4):

  a = int(input())

  if a > 0:

      sum+=a

print(sum)

# 3

sum = 0

for i in range(4):

  a = int(input())

  if a < 0:

      sum += a

print(sum)

# 4

minus = 0

plus = 0

null = 0

for i in range(4):

  a = int(input())

  if a < 0:

      minus += 1

  else:

      if a > 0:

          plus += 1

      else:

          null += 1

print('Положительных {}, отрицательных {}, нулей {}'.format(plus, minus, null))

# 5

a = int(input())

b = int(input())

polusum = (a * b) / 2

ydvoen = 2 * a * b

if a > b:

  a = polusum

  b = ydvoen

else:

  b = polusum

  a = ydvoen

print(a, b)

# 6

z = []

for i in range(3):

  z.append(input())

if z[0] == min(z):

  z[0] = 0

else:

  if z[1] == min(z):

      z[1] = 0

  else:

      z[2] = 0

print(z)

#7

z = []

for i in range(4):

  z.append(int(input()))

print(max(z)-min(z))

# 8

M = 0

kvartal = 0

M = int(input())

if (M > 1) and (M < 4):

  kvartal = 1

  print('Квартал - ', kvartal)

else:

  if (M > 3) and (M < 7):

      kvartal = 2

      print('Квартал - ', kvartal)

  else:

      if (M > 6) and (M < 10):

          kvartal = 3

          print('Квартал - ', kvartal)

      else:

          if (M > 9) and (M < 13):

              kvartal = 4

              print('Квартал - ', kvartal)

if kvartal == 0:

  print('Введён неккоректный месяц')

# 9

list = ['крыса', 'корова', 'тигр', 'заяц', 'дракон', 'змея', 'лошадь', 'овца', 'обезьяна', 'петух', 'собака', 'свинья']

god = int(input())

opred = (god - 1995) % 12 - 1

print(list[opred])

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая будет считывать введённое десятизначное число. после чего, каждую цифру этого числа необходимо вывести в новой строке. использовать нужно арифметические операции с целыми и вещественными числами. на python.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vmnk38
sonicegle
tatyana58
ognevasv555
Irina_Nikolai
kriapex
eduard495
olkay
olgakovalsky6
jablokov
sedalex
arturusinsk5
moskwa999
iracaenko153
Маргарита595