sergeevna
?>

По c++! изменение исходного массивадан двумерный массив из четного числа строк размером n×m. требуется составить программу, которая меняет местами первую строку со второй, третью — с четвертой и т. д.первая строка содержит два натуральных числа n, m (n, m≤100следующие n строк содержат по m чисел, не превосходящих 109 по модулю — элементы массива.требуется вывести n строк по m чисел в каждой — измененный массив.входные данные4 31 2 34 5 67 8 99 8 7выходные данные4 5 6 1 2 3 9 8 7 7 8 9

Информатика

Ответы

dbakun

#include <iostream>

int main(){

  int n, m;

  std :: cin >> n >> m;

  int array[109][109];

  for (int i = 0; i<n; ++i){

      for (int j = 0; j<m; ++j)

      {

            if (i==0 || i%2==0) std :: cin >> array[i+1][j];

            else std :: cin >> array[i-1][j];

      }

  }

   for (int i=0; i<n; ++i){

       for (int j= 0; j<m; ++j)

       {

            std :: cout << array[i][j]<< ' ';

       }

       std :: cout << std :: endl;

   }

}

office426
Вот тут странно выходит приведу свои соображения а там как знаете. Смотрите картинку. Значит имеем последнее положение решётки и в нём "засвечено" три окошка из возможных четырёх. Предполагаемые возможные положения окна закрашены зелёным и жёлтым. Скорей всего жёлтое окно, так как следующие два окна пустых.
 А вот дальше если укладывать решётку так как в примере получаем три тетрады (4х буквенные последовательности, полученные в одном положении решётки) и последнюю букву "т".
"исто", "мерф", "ксес", "т"
Ну последняя буква считается на месте. А вот остальная фраза не читабельна. Разве, что переставить 1ю и 2ю тетрады. На картинке поменяются местами 1е и 2е положения. Тогда получим нечто
 "мерф.исто.ксес.т" (точками я  отделил терады ) или слитно
"мерфистоксест"

Я так полагаю Мерфи Стокс ест. (Трапезничать изволит :) )

Мистер фокс прочитал про шифр “решетка” и решил тоже что-нибудь зашифровать. он взял квадрат 4 на 4
avdeevau807
Команда Повтори 3 раз означает, что ко­ман­ды Сместиться на (3, 3) и Сме­стить­ся на (1, −2) вы­пол­нят­ся три раза. В ре­зуль­та­те чего Чертёжник пе­ре­ме­стит­ся на 3·(3 + 1, 3 − 2) = (12, 3). Вы­пол­нив по­след­нюю ко­ман­ду Сместиться на (−6, 9), Чертёжник ока­жет­ся в точке (6, 12).

Чтобы Чертёжник вер­нул­ся в ис­ход­ную точку, не­об­хо­ди­мо пе­ре­ме­стить его на (−6, −12). Учитывая, на­ли­чие ко­ман­ды Повтори 3, при­хо­дим к выводу, что Команда 1 это ко­ман­да Сместиться на (−2, −4).

Правильный ответ указан под номером 3.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По c++! изменение исходного массивадан двумерный массив из четного числа строк размером n×m. требуется составить программу, которая меняет местами первую строку со второй, третью — с четвертой и т. д.первая строка содержит два натуральных числа n, m (n, m≤100следующие n строк содержат по m чисел, не превосходящих 109 по модулю — элементы массива.требуется вывести n строк по m чисел в каждой — измененный массив.входные данные4 31 2 34 5 67 8 99 8 7выходные данные4 5 6 1 2 3 9 8 7 7 8 9
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei1805
Ignateva737
ksenia15-79
Mbkozlov6
Blekjek730
Natalya1895
Lolira64
tatry2005
vnolenev
Акимцева27
kokukhin
Chuhnin195107364
pbttehnology
alexseyzyablov
Жуков219