иванович Диденко1524
?>

С требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c. формат входных данных входной поток содержит три целых числа в отдельных строках a, b и c. (a, b, c не превышают 1000 по модулю) формат выходных данных выведите одно число — искомую сумму.

Информатика

Ответы

adminaa

var a,b,c,sum:integer;

begin

writeln ('vvod chisel');

readln(a,b,c);

sum:=0;

if a →0 then

sum:=sum +a;

if b→0 then

sum:=sum+b;

if c→ 0 then

sum:=sum +c;

readln (sum);

end.

aleksey270593
Обозначим Б - число быков, К - число коров, Т - число телят.
Тогда можно записать, что
Б+К+Т=100 (1)
10Б+5К+0.5Т=100 (2)
Из (2) найдем ограничения на количества Б, К, и Т.
Б ∈ [0;10], К ∈ [0;20].
Из (1) находим, что Т=100-Б-К, Т - четное (иначе сумма не будет целой).
Эти ограничения позволят правильно построить циклы в программе.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var Б:=0 to 10 do
    for var K:=0 to 20 do begin
      var T:=100-Б-K; // из уравнения (1)
      if T.IsEven and (10*Б+5*K+T div 2=100) then
          Writeln(Б,'Б, ',K,'K, ',T,'T')
      end
end.

Результат
1Б, 9K, 90T
yanagitsina

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int n, m;

cin » n » m;// массив M на N(M-строки;N-столбцы)

vector <vector<int> > a(n, vector<int>(m, 0));// создание двумерного массива

for (int i = 0; i < n; i++)

for (int j = 0; j < m; j++)

cin » a[i][j];// заполнение массива

int counter_beging = 0, counter_end = 0;// счетчики первой и второй строки

for (int i = 0; i < n; i++) {

for (int j = 0; j < m; j++) {

if (i == 0)// первая строка

counter_beging += a[i][j];

if (i == n - 1)//последняя строка

counter_end += a[i][j];

}

}

cout « "сумма чисел 1 строки:" « counter_beging « endl;//вывод результата

cout « "сумма чисел "« n «" последней строки:"« counter_end;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c. формат входных данных входной поток содержит три целых числа в отдельных строках a, b и c. (a, b, c не превышают 1000 по модулю) формат выходных данных выведите одно число — искомую сумму.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iordanekaterina
Babushkina27
varvv15
Yelena1409
Karmelita1978
mez-omts-d5
Stenenko
Матвеев
TatianaSeliverstova64
korotaeva778898
карпова581
lor005148
luza5
tkozina
mishapavlov9
▲