vladburakoff5
?>

Составить программу которая взависимости от введенной скобки имеет её название 20

Информатика

Ответы

Yelena_Gennadevna
1. Ряд строится по принципу золотого сечения. Формула для вычисления члена последовательности такая:
x(2)=x(1)+1,
x(3)=x(2)+2,
...
x(n)=x(n-1)+n-1

В нашем алгоритме для вычисления следующего члена последовательности будем запоминать текущий член последовательности в переменной kp.
Затем получаем очередной член последовательности суммируя kp и переменную цикла i - 1. Делаем вычисления, выводим на экран и переписываем переменную kp  новым значением.
 
var i,k,kp:integer;
begin
kp:=1;
for i:=1 to 10 do begin
  k:=kp+i-1;
  kp:=k;
  writeln(k:5, k*k:6, k*k*k:8);
  end;
end.
srkushaev
1. Ряд строится по принципу золотого сечения. Формула для вычисления члена последовательности такая:
x(2)=x(1)+1,
x(3)=x(2)+2,
...
x(n)=x(n-1)+n-1

В нашем алгоритме для вычисления следующего члена последовательности будем запоминать текущий член последовательности в переменной kp.
Затем получаем очередной член последовательности суммируя kp и переменную цикла i - 1. Делаем вычисления, выводим на экран и переписываем переменную kp  новым значением.
 
var i,k,kp:integer;
begin
kp:=1;
for i:=1 to 10 do begin
  k:=kp+i-1;
  kp:=k;
  writeln(k:5, k*k:6, k*k*k:8);
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая взависимости от введенной скобки имеет её название 20
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

LidiyaBorzikh
nestruev
bolosolo77
mitin228133770
soa8690
filippovev1
denbelousov963
ski89439
tatianaavoronina66
araqsyabadalyan1988
irinatikhonov
ikhilovb76
is490
Yurevich
alexk13