ikalabuhova
?>

Создать массив о работниках из пяти записей следующего вида табельный номер (2 байта), фамилия (25 байт), пол (1 байт), количество детей (1 байт написать программу на языке ассемблер которая помещает в стек табельные номера работников женщин имеющих детей

Информатика

Ответы

dima-a
Var   
c:array[1..100] of integer; 
s,j,n,i:integer;
begin   
readln(n);  
for i:=1 to n do       
read(c[i]); 
//Сортировка по возрастанию 
for j:=1 to n-1 do   
for i:=1 to n-j do     
if c[i]>c[i+1] then     
begin       
s:=c[i];       
c[i]:=c[i+1];       
c[i+1]:=s;     
end;
//Вывод  
for i:=1 to n do     
write(c[i],' ');
writeln;
//Сортировка по убыванию 
for j:=1 to n-1 do   
for i:=1 to n-j do     
if c[i]<c[i+1] then     
begin       
s:=c[i];       
c[i]:=c[i+1];       
c[i+1]:=s;     
end;
//Вывод  
for i:=1 to n do     
write(c[i],' ');  
end.
gulnaradjhumabaeva123
*Растровый графический редактор* — специализированная программа, предназначенная для создания и обработки растровых изображений . Подобные программные продукты нашли широкое применение в работе художников-иллюстраторов, при подготовке изображений к печати типографским или на фотобумаге, публикации в интернете. Растровые графические редакторы позволяют пользователю рисовать иредактировать изображения  на экране компьютера, а также сохранять их в различных растровых форматах, таких как, например, JPEG  и TIFF , позволяющих хранить растровую графику с незначительным снижением качества за счёт использования алгоритмов сжатия с потерями, PNG  и GIF , поддерживающими хорошее сжатие без потерь, и BMP , также поддерживающем сжатие (RLE ), но в общем случае представляющем собой несжатое «попиксельное » описание изображения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать массив о работниках из пяти записей следующего вида табельный номер (2 байта), фамилия (25 байт), пол (1 байт), количество детей (1 байт написать программу на языке ассемблер которая помещает в стек табельные номера работников женщин имеющих детей
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pedalplanet
sadkofamily61
peresvetoff100015
andreykrutenko
agrilandrussia
Merkuloff78
evainvest1
podenkovaev314
arammejlumyan
Шабунина-Евгения1883
inikonovich
info126
shymilin19951783
ekasatkina
brakebox