svetkaiv
?>

Паскаль. написать программу нахождения количества элементов массива, значения которых равно 2. если таких чисел в массиве нет, то вывести на экран соответствующее сообщение

Информатика

Ответы

ognevasv555

Объяснение:

program ArrayOf2;

const

   ArraySize=10; {устанавливаем размер массива}

   MaxRandom=5; {максимальное случайное число для заполнения массива}

var

   x : array[1..ArraySize] of integer;

   i, Sum2 : integer;

begin

   Sum2:=0;

   for i:=1 to ArraySize do x[i]:=Random(MaxRandom); {в цикле заполняем массив случайными числами от 1 до заданной MaxRandom}

   for i:=1 to ArraySize do WriteLn(x[i]); {выводим на печать массив, который получился (в задании это не требовалось, можно убрать эту строку)}

   for i:=1 to ArraySize do if x[i]=2 then Sum2:=Sum2+1; {считаем двойки}

   if

       Sum2 > 0

   then

       Writeln('The quantity of 2 in this array is: ',Sum2)

   else

       WriteLn('No any 2 in this array was found')

end.

dmitrievanata83538

===== PascalABC.NET =====

begin

 var n := ReadInteger('Укажи длину массива:');

 var a := ArrRandom(n, -5, 5);

 var k := a.Println.Count(p -> p = 2);

 if k = 0 then

   Print('Нет элементов, равных 2')

 else

   Print('Число элементов, равных 2:', k)  

end.


Паскаль. написать программу нахождения количества элементов массива, значения которых равно 2. если
jenek-f

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

mgg64

ответ:1) (1 б.) Верные ответы: 3;

2) (1 б.) Верные ответы: 4;

3) (1 б.) Верные ответы: 1; 2;

4) (1 б.) Верные ответы: 3;

5) (1 б.) Верные ответы: 1;

6) (1 б.) Верные ответы: 3;

7) (1 б.) Верные ответы: 4;

8) (1 б.) Верные ответы: 1;

9) (1 б.) Верные ответы: 3;

10) (1 б.) Верные ответы: 3;

11) (1 б.) Верные ответы: 2;

12) (1 б.) Верные ответы: 3;

13) (1 б.) Верные ответы: 4;

14) (1 б.) Верные ответы: 1;

15) (1 б.) Верные ответы: 1; 2;

16) (1 б.) Верные ответы: 1;

17) (1 б.) Верные ответы: 2;

18) (1 б.) Верные ответы: 1;

19) (1 б.) Верные ответы: 3;

20) (1 б.) Верные ответы: 2;

21) (1 б.) Верные ответы: 2;

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. написать программу нахождения количества элементов массива, значения которых равно 2. если таких чисел в массиве нет, то вывести на экран соответствующее сообщение
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

polotovsky
ikosheleva215
Карева Даниил1537
retropluse832
Елизавета Александр2011
Azat859
departed744
fedoseevgleb
VladimirovichKazakova1202
Mexx9050
Маркина Ворошилина
Fedorova_79166180822
Троцкая-Ивановна
gameover98
and-syr