Объяснение:
Здесь полная аналогия с тем, как мы складываем в обычной, десятичной системе. Объясню лучше на примере.
Мы знаем, что можно складывать числа "в столбик":
24
+13
37
то есть строго разряд под разрядом. Но что мы делаем, когда в одном разряде получается число, больше 9? Правильно, переносим десяток в старший разряд!
15
+19
24 (не 214!)
Здесь та же ситуация, отличие только в том, что максимальная цифра в разряде равна 7 (как в нашей десятичной записи максимальная цифра в записи разряда равна 9, а следующее число - 10 - уже состоит из двух цифр в записи - 1 и 0). Значит, если мы хотим записать число 8 в восьмеричной записи, мы напишем это как 10₈ (нижний индекс показывает систему счисления)
А теперь попробуем сложить два числа в восьмеричной системе:
21₈
+ 16₈
37₈
Разряд под разрядом, ничего сложно. А давайте возьмем пример поинтереснее:
77₈
+ 77₈
7₈ + 7₈ = 16₈, это значит, что в младшем разряде мы напишем 6, а десятки припишем в старший разряд.
1
77₈
+ 77₈
*6
Так как 7₈ + 7₈ + 1₈ = 17₈, то 7 записываем в свой, соответствующий, разряд, а единицу в старший, получив при этом ответ 176₈
В правильности ответа можем убедиться, переведя это все в десятичную запись: 77₈ = 63, 176₈ = 126, 63 + 63 = 126, все верно.
Единственный дискомфорт при таком методе - непривычные результаты сложения. Например, 7 + 7 = 14 (в десятичной записи), но в примере выше 7₈ + 7₈ = 16₈. Поэтому тут нужно быть аккуратным!
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу для вычисления у=х/3+9 , где х принимает значение от х1 до х2 с шагом дельта х . с циклом for, repeat , while
var
x, y: integer;
begin
write ('x = ');
readln (x);
if x > 0 then
y := x - 2
else
if x = 0 then
y := 0
else
y := abs(x);
writeln ('y = ', y);
end.
Объяснение:
var
x, y: integer;
begin
write ('x = ');
readln (x);
if x > 0 then
y := x - 2
else
if x = 0 then
y := 0
else
y := abs(x);
writeln ('y = ', y);
end.