deadnobody
?>

Определить через сколько дней спортсмен похудеет до 70 кг, если в день он сбрасывает по 2% своего веса (Написать программу с циклом While)

Информатика

Ответы

Zhulanova-IP501

#include <iostream>

using namespace std;

int main()

{

  double a;

  int day = 0;

  cin>>a;

  while(a > 70){

       day++;

       a = a*98/100;

  }

   cout<<day;

}

nekataniyoleg
Всего существует 16 (ну лично я смогла только эти найти) вариантов форматирование слова.
1) Шрифт 1
2) Шрифт 2
3) Шрифт 1; полужирное
4) Шрифт 2; полужирное
5) Шрифт 1; полужирный; курсив
6) Шрифт 2; полужирный; курсив
7) Шрифт 1; полужирный; курсив; подчеркнутое
8) Шрифт 2; полужирный; курсив; подчеркнутое
9) Шрифт 1; курсив
10) Шрифт 2; курсив
11) Шрифт 1; курсив; подчеркнутое
12) Шрифт 2; курсив; подчеркнутое
13) Шрифт 1; подчеркнутое
14) Шрифт 2; подчеркнутое
15) Шрифт 1; полужирный; подчеркнутое
16) Шрифт 2; полужирный; подчеркнутое
mira15963256
1) Определяем общее количество бит: 16 х 640 х 480 = 4 915 200
С учетом того, что в байте 8 бит, а 1 КБ=1024 Б получим
4 915 200 / 8 / 1024 = 600 (КБ)

2) Определяем общее количество бит с учетом того, что в палитре True Color для цвета отводится 24 бита: 1600 х 1200 х 24 = 46 080 000 (бит).
После преобразования файла для Интернет он будет представлен в восьмибитной палитре ( 256 = 2⁸ ) и займет объем
1400 х 900 х 256 = 10 080 000 (бит).
Разница в объемах составит  46 080 000 -  10 080 000 = 36 000 000 бит.
С учетом того, что в байте 8 бит, а в мегабайте 1024 х 1024 байт получим, что пространство на диске сократиться на
36 000 000 / (8 х 1024 х 1024) ≈ 4.29 (МБ)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определить через сколько дней спортсмен похудеет до 70 кг, если в день он сбрасывает по 2% своего веса (Написать программу с циклом While)
Ваше имя (никнейм)*
Email*
Комментарий*