Гаевая1290
?>

нужно написать программу и обязательно в виде функии(перегрузка функции) если решите кину на телефон 50 р В одномерном массиве, состоящем из n элементов: а) вычислить сумму положительных элементов массива; б) вычислить произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами; в) упорядочить элементы массива по убыванию нужно написать программу и обязательно в виде функии(перегрузка функции)

Информатика

Ответы

S.V. Zhoraevna1677
1)constn=10;var i,k,min:integer; mas: array [1..n] of integer; begin  randomize;  for i:=1 to n do   mas[i]:=random(65);   min:=mas[1];   for i:=1 to n do    if mas[i] < min then    begin   min:=mas[i];   k:=i;   end;   for i:=1 to n do   write(mas[i]:4);   writeln();   writeln('minimalnoe=',min);   writeln('index=',k);   end.
2)constn=10;var i,k,min:integer; mas: array [1..n] of integer; begin  randomize;  for i:=1 to n do   mas[i]:=random(65);   for i:=1 to n do    write(mas[i]:4);  for i:=1 to n do    if mas[i] mod 3 = 0 then   mas[i]:=0;   writeln();   for i:=1 to n do    write(mas[i]:4);   end.
1. в одномерном массиве найти значение и номер минимального элемента . 2. в одномерном массиве замен
1. в одномерном массиве найти значение и номер минимального элемента . 2. в одномерном массиве замен
Zolotnik974620
1) program p1;
var a,b:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
if(a>=b) then writeln('максимальное число: ', a) else  writeln('максимальное число: ', b);
end.

2)
program p1;
procedure MaxNumber(a,b: integer; var max: integer);
begin
   if a>=b then max:=a else max:=b;
end;
var a,b,c,d,m:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
writeln('Введите 3-е число: ');read(c);
writeln('Введите 4-е число: ');read(d);
MaxNumber(a,b,m);
MaxNumber(m,c,m);
MaxNumber(m,d,m);
writeln('максимальное число: ',m);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно написать программу и обязательно в виде функии(перегрузка функции) если решите кину на телефон 50 р В одномерном массиве, состоящем из n элементов: а) вычислить сумму положительных элементов массива; б) вычислить произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами; в) упорядочить элементы массива по убыванию нужно написать программу и обязательно в виде функии(перегрузка функции)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Карен
NIKOLAEVNA
blackpoint2020273
Радецкая264
irnik65
pannotolstova488
Richbro7
Евгения-Валерий
УМОЛЯЮ СДЕЛАЙТЕ ИНФОРМАТИКУ!
arteevdimon
sargisyan
mmreznichenko
lakeeva90
nopel91668
ilyatamurov
Mikhail_Magomed635
▲