andreokiseleo69421
?>

Задача по машине Поста: На ленте машины Поста расположен массив из 2 * N-1 меток. составить программу отыскания средней метки массива и ее истиранию.

Информатика

Ответы

pannotolstova488
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
Шитенков

#include <iostream>

using namespace std;

bool srav(int a, int b)

{

if (a > b)

 return 1;

else

 return 0;

}

int main()

{

int number = 0;

int AB = 1, CD = 1;

cout << "Input A , B\n";

//Произведение A на B

for (int i = 0; i <= 1; i++)

{

 cin >> number;

 AB *= number;

}

cout << "A*B = " << AB << endl;

for (int i = 0; i <= 1; i++)

{

 cin >> number;

 CD *= number;

}

cout << "C*D = " << CD << endl;

if(srav(AB,CD))

 cout<<"A*B > C*D";

else

 cout << "C*D > A*B";

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача по машине Поста: На ленте машины Поста расположен массив из 2 * N-1 меток. составить программу отыскания средней метки массива и ее истиранию.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

daryagulyaeva
gutauta6
natura-domA90
Paradismebel
Grigorev_Nikita794
belegaj98
avdushinalizza1
vallium8354
Vasilevskii
bergamon
самир1078
Екатерина15
Aleksandr768
Test Станислав
kashxb2056