озерская_Мария1234
?>

с задания в Python. 3. Опишите на языке Python строковый тип переменной (буквенный) 4. Опишите на языке Python целочисленный тип переменных 5. Опишите на языке Python команду, позволяющую вводить данные с клавиатуры 6. Опишите на языке Python команду, позволяющую вывести информацию на экран монитора. 7. Опишите на языке Python вещественный тип переменных 8. Опишите на языке Python следующее условие: "если значение переменной s больше значения переменной d, то максимуму m присвоить значение переменной s". Примечание: Отступы обязательно показывать( для обозначения отступа можно использовать символ #), синтаксис языка тоже никто не отменял 9. Напишите программу, вычисляющую площадь и периметр прямоугольника со сторонами a и b. если площадь больше периметра, то программа должна вывести значение площади, а если периметр больше, то программа должна вывести значение периметра. Оформление программы: см задание 8

Информатика

Ответы

kamalfayed229
Задание 3

p = 0, s = 1

0 > 5 ? False

s = s + p = 1 + 0 = 1

p = p + 2 = 0 + 2 = 2

2 > 5 ? False

s = s + p = 1 + 2 = 3

p = p + 2 = 2 + 2 = 4

4 > 5 ? False

s = s + p = 3 + 4 = 7

p = p + 2 = 4 + 2 = 6

6 > 5 ? True

Выход из цикла

ответ

7

Задание 4

y = 5, z = -3

5 < 5 ? False

y = y + z = 5 + (-3) = 2

x = y + z = 2 + (-3) = -1

ответ

-1

Задание 5

a = 1, b = 1

1 < 9 ? True

1 < 1 ? False

b = b + 2 = 1 + 2 = 3

a = a + 1 = 1 + 1 = 2

...

Вторая итерация цикла и последующие будут во втором условии принимать значение True, следовательно:

Первое условие у нас завершится только тогда, когда a < 9, то есть при a = 2 (не касается цикла) + 3 + 3 + 3 = 11. Всего будет 3 цикла. Все 3 цикла к b будет прибавляться 2.

b = 3 + 2 · 3 = 3 + 6 = 9

ответ

9

mansur071199486

Я исправил ошибки, теперь она работает корректно, но если тебе нужно обязательно использовать if..else, то оставять коммент, я перепишу

#include <iostream>

using namespace std;

int main()

{

 setlocale(0, "Rus");

 int osenka; ;

 cout << "Введите произвольную цифру от 2 до 5: ",

  cin >> osenka;

 if (osenka == 5) // Если введенная цифра равна 5.

  cout << "Вы получили оценку «5» \n";

 if (osenka == 4) //Если введенная цифра равна 4

  cout << "Вы получили оценку «4». \n";

 if (osenka == 3) //Если введенная цифра равна 3

  cout << "Вы получили оценку «3». \n";

 if (osenka == 2)

  cout << "Вы получили оценку «2».\n";

 return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с задания в Python. 3. Опишите на языке Python строковый тип переменной (буквенный) 4. Опишите на языке Python целочисленный тип переменных 5. Опишите на языке Python команду, позволяющую вводить данные с клавиатуры 6. Опишите на языке Python команду, позволяющую вывести информацию на экран монитора. 7. Опишите на языке Python вещественный тип переменных 8. Опишите на языке Python следующее условие: "если значение переменной s больше значения переменной d, то максимуму m присвоить значение переменной s". Примечание: Отступы обязательно показывать( для обозначения отступа можно использовать символ #), синтаксис языка тоже никто не отменял 9. Напишите программу, вычисляющую площадь и периметр прямоугольника со сторонами a и b. если площадь больше периметра, то программа должна вывести значение площади, а если периметр больше, то программа должна вывести значение периметра. Оформление программы: см задание 8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

koptevan6
alexkortyukov
a60ikurgannikova
meu72
AlekseiMardanova
tanya62soldatova72
Ofelya1308
shmanm26
marinamarinazmeeva2444
Васильевна_Наталья
tanyashevvvv
ikosheleva215
Fateevsa9
Mikhailovich_Viktoriya
Alekseevich_Viktorovna
▲