margo929
?>

Составьте блок-схемы к следующим задачам: 1. Напишите программу, которая возводит в степень заданное число. 2. Напишите программу, которая выводит на экран таблицу умножения для заданного числа. 3. Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено 0. 4. Найдите максимальное число из 10 любых положительных чисел.

Информатика

Ответы

Zashchitin Denis

var
   A:array [1..5] of integer;
   i,min,s:integer;
begin
   for i:= 1 to 5 do
   begin
      write('Введите ',i,' элемент массива: ');
      readln(A[i]);
   end;
   min:=A[1];
   s:=0;
   write('Введенный массив: ');
   for i:= 1 to 5 do
   begin
      write(A[i]:4);
      if A[i]<min then min:=A[i];
      s:=s+A[i];
      A[i]:=A[i]*2;
  end;
  writeln;
  writeln('Минимальный элемент массива = ',min);
  write('Удвоенные значиния элементов массива: ');
  for i:= 1 to 5 do write(A[i]:4);
  writeln;
  writeln('Среднее арифметическое элементов массива = ',s/5);
  end.

moskvichkabakery56

2 925 символов

Объяснение:

I = K * i

I - информационный объём текстового сообщения (размер файла, содержащего сообщение)

K - количество символов в сообщении

i - информационный вес одного символа (число бит, используемых для записи одного символа)

N = 2^i  

N - мощность алфавита (количество символов в алфавите)

i - информационный вес одного символа (число бит, используемых для записи одного символа)

Дано:

I = 2,5 Кбайт = 20 480 бит

N = 128 символов

Найти:

K

128 = 2^i

128 = 2⁷

i = 7 бит

I = K * i

K = I / i

K = 20 480 / 7 ≈ 2 925 символов

1 Кбайт = 1 024 байт

1 байт = 8 бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте блок-схемы к следующим задачам: 1. Напишите программу, которая возводит в степень заданное число. 2. Напишите программу, которая выводит на экран таблицу умножения для заданного числа. 3. Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено 0. 4. Найдите максимальное число из 10 любых положительных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*