intermar2000
?>

Даны x, y, z. Напишите программу для вычисления значения арифметического выражения: a= 2x+y-3z/x*x+5​

Информатика

Ответы

Plotnikovangav

ответ:Program Test,

Var x, y, z: integer; a1, a2: real;

Begin

Writeln('Введите значения х, y, z');

Readln(x, y, z);

a1 := (x + y - z) / (x * 2 + 2);

a2 := 5 * ((2 * x - z) / (3 + y * 2));

Writeln();

Writeln('a1 = ', a1);

Writeln('a2 = ', a2);

End.

P.S. Программа на паскале; На будующее - пиши условие задачи понятнее. Не х2, а х * 2 или 2х, а то это можно посчитать как х^2

ответ к заданию 1 - это а1, а к заданию 2 - это а2

Объяснение:

mpityk

function F(x: real): real;

begin

 F := 3 * sin(x) + 2 * sqr(x) - 1;

end;

var

 a, b, h, x, Fa, Fx: real;

begin

 Write('Введите через пробел начало интервала, конец и шаг: ');

 Readln(a, b, h);

 x := a; Fa := F(a);

 repeat

   Fx := F(x);

   if Fx = 0 then Writeln('Найден корень ', x:0:3)

   else

   if Fx * Fa < 0 then

     Writeln('Найден интервал изоляции корня (', a:0:3, ';', x:0:3, ')');

   a := x; Fa := Fx; x := x + h

 until x > b;

end.

Тестовое решение:

Введите через пробел начало интервала, конец и шаг: 0 1.95 0.15

Найден интервал изоляции корня (0.150;0.300)

Введите через пробел начало интервала, конец и шаг: -5 5 0.1

Найден интервал изоляции корня (-1.500;-1.400)

Найден интервал изоляции корня (0.200;0.300)

Объяснение:

Лови! Удачки!
azarovaelena19812

1)

import random

number_list = []

for n in range(10):

   number_list.append(random.randint(-10, 10))

print(number_list)

number_list = [number * -1 for number in number_list]

print(number_list)

2)

import random

number_list = []

for n in range(10):

   number_list.append(random.randint(-10, 10))

amount = 0

for number in number_list:

   amount += number

print(amount)

3)

import random

number_list = []

for i in range(10):

   number_list.append(random.randint(-10, 10))

number_list = [number ** 2 for number in number_list]

amount = 0

for n in number_list:

   amount += n

print(amount)

4)

import random

number_list = []

for n in range(10):

   number_list.append(random.randint(-10, 10))

negative_numbers = []

positive_numbers = []

for number in number_list:

   if number < 0:

       negative_numbers.append(number)

   elif number > 0:

       positive_numbers.append(number)

amount_positive = 0

amount_negative = 0

for n in negative_numbers:

   amount_negative += n

print('сумма отрицательных чисел: ' + str(amount_negative))

for p in positive_numbers:

   amount_positive += p

print('сумма положительных: ' + str(amount_positive))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны x, y, z. Напишите программу для вычисления значения арифметического выражения: a= 2x+y-3z/x*x+5​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Николаевич-Золотая832
nekrasovaolga27
afoninia
grigoriev8
msangelika1010
хуйдрочил_Анастасия
lmedintseva6
Rinatum1978
Irinagarmonshikova
abrolchik8511
Struev730
parolmm
DudukinSerega2507834
kristal1
▲