Информатика умоляю. Составьте программу по вычисление длины окружности.Составьте программу нахождения остатка деления целочисленного числа k на n.Найдите значение вычисления выражений
Задача 7. ВОДОЛАЗКА Задача 2. после 6 применений 64 четных цифры (после каждого применения их количество увеличивается в 2 раза) Задача 1. не может быть Даша второй, т.к. это утверждение в 4 и 5 строках. Не может быть третьей Ира (предполагается в 3 и 5 строках). Значит первая Маша. А Даша и Ира - не призеры. Из 4-й строки получаем. что и Боря не призер. Из 1 и 3 строки получаем, что Вася - не призер (т.к. указано что Вася второй и Вася третий). Значит призер Таня (не первая и не третья, значит - вторая). Из 2 строки получаем, что и Гена не призер. Остается Антон - третий ответ: Маша, Таня, Антон Задача 3. Всего можно составить 60 трехзначных чисел. Числе. меньших 200, 12. Вероятность 12/60=0,2 Задача 9. 16 Задача 4. Можно (Земля-Марс-юпитер-Венера-Меркурий) Задача 6. 370 343 640 613 910 901 271 253 550
var
n, i, aon_i, k: integer;
f: boolean;
function AmountOfNumbers(n: integer): integer;
var
s: integer;
begin
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10;
end;
AmountOfNumbers := s;
end;
begin
readln(n);
for i := 0 to n do
begin
f := true;
aon_i := AmountOfNumbers(i);
for k := 2 to 9 do
f := f and (aon_i = AmountOfNumbers(k * i));
if f then writeln(i);
end;
end.
Объяснение: