aynaakzhigitova
?>

1. Будет ли выполняться циклическая часть программы, если логическое выражение в конструкции do ... while истинно с самого начала ?​

Информатика

Ответы

Vasilevich Fokin

будет

Объяснение:

Galina-Marat1096

В этой задаче нам нужно подсчитывать количество чисел и искать максимум среди подсчитанных количеств. Алгоритм будет такой: если очередное число равно `2`, то увеличиваем счётчик количества, если же нет, то это означает, что подпоследовательность закончилась, и надо проверять, не превзошли ли мы максимум, а потом текущий счётчик сбрасывать в `0`. И ещё нужно сделать такую проверку после цикла, поскольку последовательность может закончиться на `2`.

var a,k,max:integer;

     begin

      max:=0;

      k:=0;

      read(a);

      while a <> 0 do begin

       if a = 2

       then k := k + 1

  else begin

   if k > max then max := k;

   k := 0

  end;

 read(a);

 end;

 if k > max then max := k;

 writeln(max)

     end.

alukyanov

#include <iostream>

using namespace std;

int getABC(double xA, double yA, double xB, double yB,

       double &A, double &B, double &C)

{

   A = yA - yB;

   B = xB - xA;

   C = xA * (yB - yA) + yA * (xA - xB);

   return 0;

}

int getM(double a1, double b1, double c1, double a2, double b2, double c2,

       double &xM, double &yM)

{        

   double d = a1 * b2 - a2 * b1;

   if (d != 0)

   {

       double dx = c2 * b1 - c1 * b2;

       double dy = a2 * c1 - a1 * c2;

       xM = dx / d;

       yM = dy / d;

       return 0;

   }

   else

       return -1;

}

int main()

{

   double x1, x2, x3, x4, y1, y2, y3, y4;

   cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3 >> x4 >> y4;

   double a1, b1, c1, a2, b2, c2, xM, yM;

   getABC(x1, y1, x2, y2, a1, b1, c1);

   getABC(x3, y3, x4, y4, a2, b2, c2);

   cout << a1 << " " << b1 << " " << c1 << endl;

   cout << a2 << " " << b2 << " " << c2 << endl;

   int r = getM(a1, b1, c1, a2, b2, c2, xM, yM);

   if (r == 0)

       cout << xM << " " << yM;

   else

       cout << "No cross";

   return 0;

}


Необходимо написать программу на С++ или на питоне. Две пересекающиеся прямые заданы точками: A(x1,y

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Будет ли выполняться циклическая часть программы, если логическое выражение в конструкции do ... while истинно с самого начала ?​
Ваше имя (никнейм)*
Email*
Комментарий*