Tomilova1686
?>

Если число А пооложительное, прибавить 5, если отрицательное, отнять 5 (памагити быстринька)​ (паскаль)

Информатика

Ответы

propercarwashes275

program iftrain;

var a: integer;

begin

a = число

if a > 0 then

a := a + 5

else

a := a - 5

end.

end.

ocik1632933
Program p1;
var
n,a,i,max,fl:integer;
begin
writeln('Введите кол-во участников>>');
readln(n);
max:=0; fl:=0;
for i:=1 to n do
 begin
 writeln('Введите кол-во правильных ответов, данных участником ',i); 
 readln(a);
 if (a > max) then max:=a;
 if a=0 then fl:=1;
 end;
if fl=1 then writeln('YES') else writeln('NO');
writeln('Победитель набрал ',max,' ');
end.

Пример:
Введите кол-во участников>> 5
Введите кол-во правильных ответов, данных участником 1 15
Введите кол-во правильных ответов, данных участником 2 18
Введите кол-во правильных ответов, данных участником 3 0
Введите кол-во правильных ответов, данных участником 4 8
Введите кол-во правильных ответов, данных участником 5 10
YES
Победитель набрал
sochi-expert
Смотри на скриншот я сделал просто не хочу чтоб форматировка текста портилась.Все работает!
const n=3;m=4;
var a:array [1..n,1..m] of integer;    i,j,k,max:Integer;    ind:array [0..1] of Integer=(1,1);
begin 
Randomize; 
 for i:=Low(a) to High(a) do 
 for j:=Low(a) to High(a[1]) do 
   a[i,j]:=Random(100); 
for i:=Low(a) to High(a) do 
  begin   
  writeln;   
for j:=Low(a) to High(a[1]) do 
 write(a[i,j]:3); 
 end; 
 max:=a[1,1]; 
 for i:=Low(a) to High(a) do   
for j:=Low(a) to High(a[1]) do
    if a[i,j]> max then   
  begin 
     max:=a[i,j];   
    ind[0]:=i;     
  ind[1]:=j;     
end;     
writeln; 
Writeln(' Max element: ',max);
 Write(' Index: '); 
 for i:=0 to 1 do 
 write(ind[i],' ');
 Readln;
end. 
Составьте программу, определяющую максимальный элемент и его индексы матрицы а размерами mxn(паскаль

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Если число А пооложительное, прибавить 5, если отрицательное, отнять 5 (памагити быстринька)​ (паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Лифанов_Ольга
Valentina1520
danaya3005
КалюкМарасанов1026
dariagromova54
Kuznetsova1639
sargisyan77
azarov8906
Galina_Yurevna
gbg231940
Vitalevna1186
potap-ver20065158
bolosolo77
gallush9
KosarinPotemkina1888