nikolotovas
?>

Вариант 4. Составьте программу рисования узора с использованием вс алгоритма. Программа КуМир. Сделать то что серым

Информатика

Ответы

nikdenly

#include <iostream>

using namespace std;

double y(double a, double b, double c, double x) {

   if (c == x && b + c + x != 0)

       return ((a + b) * (a + c) * (a + x)) / (b + c + x);

   if (c != x && 1 + b != 0 && 1 + a != 0 && a / (1 + b) + b / (1 + a) >= 0)

       return sqrt(a / (1 + b) + b / (1 + a));

   return -1e9 - 7;

}

signed main() {

   double a, b, c, x, ans;

   cin >> a >> b >> c >> x;

   ans = y(a, b, c, x);

   ans == -1e9 - 7 ? cout << "No solution" : cout << ans;

}

ikosheleva215
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('Количество элементов массива ');
  var m:=ArrRandom(n,-50,50); m.Println(', ');
  var a:=0; var b:=0; var c:=0;
  for var i:=0 to n-1 do begin
    if m[i]>0 then a:=a+m[i];
    if m[i]<m[b] then b:=i;
    if m[i] mod 5 = 0 then Inc(c)
  end;
  var w:=(b+1)+a/(c+1);
  WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
  Writeln('Принято, что элементы массива нумеруются от единицы')
end.

Тестовое решение:
Количество элементов массива  13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы

Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наимень

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вариант 4. Составьте программу рисования узора с использованием вс алгоритма. Программа КуМир. Сделать то что серым
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tany821
mail9
Герасимова107
zolotayaoxana1982
ЕленаАлександровна381
vasenkova1981
myatadinamo
natakrechko
victoria-112296363
airon-082054
maria
Yekaterina_Popova1413
jim2k
sergeevna
tarhan1221