Anatolevich_Kulikov1229
?>

Составить программу, вычисляющую значения функции y = x^2 на промежутке от -4 до 4 с шагом 1.

Информатика

Ответы

Voronina747
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
alex091177443
Задачи 1,2,4:
/ PascalABC.Net 3.0, сборка 1066
var
  n:BigInteger;
begin
  var s:=ReadlnString('Введите натуральное число: ');
  If BigInteger.TryParse(s,n) then begin
    var c:=ReadChar('Введите проверяемую цифру: ');
    Writeln(c, ' встречается в ',s,' ',s.Where(x->x=c).Count,' раз');
    Writeln('Максимальная цифра числа: ',s.Where(x->x=s.Max).Distinct);
    Writeln('Перевертыш: ',s.Inverse);
    end
  else Writeln('Ошибка при вводе числа')
end.

Тестовое решение:
Введите натуральное число:  355678679650768680078676985643546809678546263435
Введите проверяемую цифру:  4
4 встречается в 355678679650768680078676985643546809678546263435 4 раз
Максимальная цифра числа: [9]
Перевертыш: 534362645876908645346589676870086867056976876553

Задача 3
// PascalABC.Net 3.0, сборка 1066
begin
  var m:int64:=-1;
  var n:int64:=0;
  Writeln('Принимаются неотрицательные целые числа');
  while (n>=0) and (m<n) do begin
    m:=n;
    n:=ReadInteger('Введите число: ')
  end;
  if m>=n then Writeln('Последовательность невозрастающая')
  else Writeln('Последовательность возрастающая')
end.

Тестовое решение:
Принимаются неотрицательные целые числа
Введите число:  4
Введите число:  6
Введите число:  12
Введите число:  83
Введите число:  170
Введите число:  214
Введите число:  170
Последовательность невозрастающая

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, вычисляющую значения функции y = x^2 на промежутке от -4 до 4 с шагом 1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mail5
reception
Voronin-Albertovich
alexseyzyablov
tatry2005
alex091177443
razumeiko0790
gladkihvv
gumirovane2294
Сурат1199
Stepanovich_Makarov
соловьев_Куркина
Railyan
tcmir
Татьяна902