aggeeva
?>

с паскалем и можете в программе сразу ввести отрезки и шаг а то я ничего не понимаю Задание: Составьте программу вычисления значений функции F(x) на отрезке [a;b] с шагом h. Первый столбец которой - значение аргумента, второй - соответствующее значение функции. Функция: F(x) = 2cosx-1

Информатика

Ответы

sbalashov62

var

 n,k:integer;

 a:array of integer;

 s,k2:real;

begin

 

 {Ввод размера массива и элементов массива}

 while n<3 do begin

   write('Введите размер массива - '); readln(n);

   if n<3 then writeln('[Массив слишком короткий]');

 end;

 setLength(a,n);

 for var i1:=0 to n-1 do begin

   write('Введите ',i1+1,' элемент массива - '); readln(a[i1]);

 end;

 

 {Вычесление минимальной суммы трёх соседних элементов массива}

 s:=a[0]+a[1]+a[2];

 for var i2:=2 to n-2 do begin

   k:=a[i2-1]+a[i2]+a[i2+1];

   if s>k then s:=k;

 end;

 writeln('Минимальная сумма трёх соседних элементов = ',s);

 

 {Выполнение условия чётности и нечётности}

 k2:=s;

 while k2>=2 do begin

   k2:=k2-2;

 end;

 if k2=0 then s:=sqr(s)

 else s:=sqrt(s);

 write('ответ: ',s:0:3);

 

end.

servik78

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int A, B, C, tmp;

           Console.Write("Введите A: ");

           A = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите B: ");

           B = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите C: ");

           C = Convert.ToInt32(Console.ReadLine());

           tmp = A;

           A = C;

           C = B;

           B = tmp;

           Console.WriteLine("Новые значения:");

           Console.WriteLine("A = " + A);

           Console.WriteLine("B = " + B);

           Console.WriteLine("C = " + C);

       }

   }

}


Необходимо написать код на C# и составить блок схему: Даны переменные A, B, C. Изменить их значения

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с паскалем и можете в программе сразу ввести отрезки и шаг а то я ничего не понимаю Задание: Составьте программу вычисления значений функции F(x) на отрезке [a;b] с шагом h. Первый столбец которой - значение аргумента, второй - соответствующее значение функции. Функция: F(x) = 2cosx-1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

danaya3005
Vasilisan
garunkhachatryan
larson96
evge-borisova2
Бегун-Марина
juliat200520
Vera_Shuklin
shyroshka836103
kobzev-e
ogonizoloto
elenakarpova709
ЮрьевичКарпова1564
lescha-77766
olgolegovnak