sigidinv
?>

Написать программу на языке Паскаль, которая запрашивает у пользователя три числа и выводит их на экран через запятую

Информатика

Ответы

oooviktoria17

Объяснение:

Листинг программы и результат работы в приложении:


Написать программу на языке Паскаль, которая запрашивает у пользователя три числа и выводит их на эк
Написать программу на языке Паскаль, которая запрашивает у пользователя три числа и выводит их на эк
coalajk
#include <iostream>
#include <ctime>
#include <stdlib.h>
using namespace std;

double Sum(int *A, int N, int C, int M);

int main()
{
    srand(time(0));
    int N, C = 19, M = 30;
    cout << "N = ", cin >> N;
    int Train[N];
    for(int i = 0; i < N; i++)
        cout << (Train[i] = rand() % (M+1)) << " ";
    cout << "\nSum = " << Sum(&Train[0], N, C, M);;
    return 0;
}

double Sum(int*A, int N, int C, int M)
{
    double S = 0;
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        S += A[i]*C;
        k +=M - A[i];
    }
    cout << "\nk = " << k;
    return S;
}
margo55577869
#include <iostream>
#include <ctime>
#include <stdlib.h>
using namespace std;

double Sum(int *A, int N, int C, int M);

int main()
{
    srand(time(0));
    int N, C = 19, M = 30;
    cout << "N = ", cin >> N;
    int Train[N];
    for(int i = 0; i < N; i++)
        cout << (Train[i] = rand() % (M+1)) << " ";
    cout << "\nSum = " << Sum(&Train[0], N, C, M);;
    return 0;
}

double Sum(int*A, int N, int C, int M)
{
    double S = 0;
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        S += A[i]*C;
        k +=M - A[i];
    }
    cout << "\nk = " << k;
    return S;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль, которая запрашивает у пользователя три числа и выводит их на экран через запятую
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Борисовна_Дмитриевич1003
olesya-cat8601
sapelnikovk-74
moscow053988
evgeniy1988486
fominovaVladislav1346
Anna572
choia
Igorevich1559
dkedrin74038
snopok66
Berezovskaya
belegaj98
korneevaa
ktatarinova