Yuliya_Viktoriya316
?>

написать программу в Паскаль и составить блок- схему : Найти сумму всех натуральных чисел от 1 до m используя формулу суммы членов арифметической прогрессии.

Информатика

Ответы

oshemkov579

program arifmseq;

var m,sum:real;

begin

writeln ('Введите число m');

read (m);

sum:=((1+m)/2)*m;

writeln ('сумма всех натуральных чисел от 1 до m=',sum);  

end.

Объяснение:

Gpack54
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.
ietishkin

ответ:Дерево игры - в прилагаемом файле. У игрока, делающего ход первым (Пети) есть выигрышная стратегия: первый ход должен быть +3 (в куче получится 13 камней). В этом случае при ходе второго игрока (Вани) +3 (в куче 16 камней) первый (Петя) выигрывает ходом *2 (в куче 32 камня); при ходе второго игрока (Вани) *2 (в куче 26 камней) первый (Петя) также выигрывает ходом *2 (в куче 52 камня). Второй игрок (Ваня) может выиграть только в случае, если первый (Петя) сделает начальный ход *2 (в куче 20 камней), следующий ход (Вани) *2 (в куче 40 камней) приводит к выигрышу.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу в Паскаль и составить блок- схему : Найти сумму всех натуральных чисел от 1 до m используя формулу суммы членов арифметической прогрессии.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Девяткина_Арсений
Kondratchik Vladimir
Галина-Юлия1292
ambstroy
sargisyan77
Rinatum1978
lera4075
juliajd
kyrtlab39
vladimirdoguzov
andy74rus36
Makarov
Vasilevna_Utenkova651
shoora
mali2681208