Голосова-Лобанов1555
?>

C++, задача с массивом и разрядностью чисел Вводится последовательность из N положительных целых чисел. Определить разрядность каждого числа. Написать программу на с++, желательно только со стандартными библиотеками. Написать через for, while, do while (разными циклами)

Информатика

Ответы

maxchemaxim14

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

setlocale(LC_ALL,"russian");

cout << "Введите размер массива: ";

int N;

cin >> N;

N=N--;

unsigned int a[N];

for (int b = 0; b<=N; b++)

{

cout << "Введите число номер " << b << ": ";  

cin >> a[b];

}

for(int i=0; i<=N; i++)

{

if(a[i]<=255)

{

 cout << "Количество разрядов числа " << a[i] << " - 8" << endl;

}

if(a[i]>=256 && a[i]<=65535)

{

 cout << "Количество разрядов числа " << a[i] << " - 16" << endl;

}

if(a[i]>=65536 && a[i]<=4294967295)

{

 cout << "Количество разрядов числа " << a[i] << " - 32" << endl;

}

}

   system("pause");

   return 0;

}

Надеюсь, правильно понял определение разрядов.

Есть пожелания - в комментарии

Andreevich
Const
n=5;m=10;
var
b:array[1..n,1..m]of integer;
i,j,k,buf,l:integer;
begin
    for i:=1 to n do
         begin
           writeln;
              for j:=1 to m do
                 begin
                    b[i,j]:=random(50);
                    write(b[i,j]:4);
                  end;
           end;
writeln;
for j:=1 to m do
   begin
      k:=0;
       for i:=1 to n-1 do
            if b[i,j]<b[i+1,j]then
                k:=k+1;
            if k=n-1 then
               buf:=buf+1;
    end;
k:=0;
for l:=2 to m do
   if l mod 2=0 then
     for i:=1 to n-1 do
       for j:=i+1 to n do
           if b[i,l]>b[j,l]then
               begin
                   k:=b[i,l];
                   b[i,l]:=b[j,l];
                   b[j,l]:=k;
                end;
writeln('увеличилось  ',m div 2-buf);
for i:=1 to n do
   begin
      writeln;
          for j:=1 to m do
             write(b[i,j]:4);
    end;
end.
       
                  
Vik1744184

Укажите номер наименьшего из трех числел

1. 101010²

2.2F [16]

3. 51[8]

Укажите, в каких системах счисления возможна следующая запись числа :121090

1. В десятичной

2. В шестнадцатеричной.

3. В восьмеричной.

4. В двоичной.

Установите соответствие.

110. 1.7

001. 2.5

101. 3.3

010. 4. 1

111. 5.2

100. 6.4

011. 7.6

Укажите, в каких системах счисления невозможна следующая запись числа: 101088

1. В десятичной

2. В двоичной

3. В восмеричной

4. В шестнадцатеричной

Запишите десятичный эквивалент восьмеричной числа 55[8]

Как будет записано 25 в восьмеричной системе счисления

Объяснение:хах

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++, задача с массивом и разрядностью чисел Вводится последовательность из N положительных целых чисел. Определить разрядность каждого числа. Написать программу на с++, желательно только со стандартными библиотеками. Написать через for, while, do while (разными циклами)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Valentina
tanias
annino
emartynova25
olyavoznyak
dimaproh
Karmelita1978
gymnazium
Stenenko
dilanarthur27
yurassolo747
polariskirov
карпова581
ПетровичЖивотовская1245
unalone5593
▲