Сергеевич1907
?>

1Сколько раз выполнится тело цикла в следующих фрагментах программ: а) for i:= 1 to 15 do c:=2*i; б) for i:= -4 to 4 do c:=2*i; г) for i:= 4 to 2 do c:=2*i; 2Сколько раз выполнится тело цикла в следующих фрагментах программ: а) x:=10; while x>=0 do x:=x-1; ответ 11 б) x:=0; while x>=0 do x:=x-1; ответ 1 в) x:=0; while x>0 do x:=x-1; ответ 0 3. Определите значение переменной X после выполнения следующего фрагмента программы: x:=1; y:=5; while x+y<10 do begin x:=x+2; y:=y-1; end; 4. Выберите номер фрагмента программы, выполняющего такие же действия, что и приведенный ниже: for i:= 1 to 5 do begin x:=x+2*i; x:=x+1; end; 1) while i< 5 do begin x:=x+2*i; x:=x+1; i:=i+1; end; 2) while i<= 5 do begin x:=x+2*i; x:=x+1; end; 3) i:=1; while i<=5 do begin x:=x+2*i; x:=x+1; i:=i+1; end;

Информатика

Ответы

k-serga1

for k:= -1 to1 do = 3 раза

for k: = 10 to 20 do ...21 раз

for k: =20 to 10 do ...  0 раз

k:= 5; r:=15; for i:= k+1 to r-1 do ...9 раз

k:= 5; r:= 15; for i:= 0 to k*r do ...76 раз

k: = r ; for i:= k to r do ..0 раз

Объяснение:

nikv568734
Const
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;

begin
//генератор случайных чисел. Диапазон от 1 до 10.
 for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    a[i,j]:=random(10)+1;
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Проверка условия и переприсвоение, если верно.
 for i:=1 to n do
  for j:=1 to n do
   begin
    if (((i+j) mod 2)=0) then
     a[i,j]:=a[1,2];
   end; 
 
//Вывод полученного массива.
  for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Ожидание.
readln();
end.
dima0218687
Вопросы по горизонтали:

7.Служит для выбора одного из взаимоисключающих вариантов, которые представлены в форме белых кружков.
8.В крайней правой части Панели задач находятся…
10.Важнейший элемент графического интерфейса, который можно наблюдать, например, при открытии папки.
14.Это позволяет плавно изменить значение параметра.
17.Перемещение объекта с нажатой кнопкой.
18. Важное координатное устройство ввода, часто используемое для работы с графическим интерфейсом.
19.Объект, содержащий файлы.

Вопросы по вертикали:

1.Страница диалоговой панели.
2.Раскрывающийся…. - текстовое поле, снабженное кнопкой с направленной вниз стрелкой.
3. Нажатие кнопки Пуск открывает главное… Windows.
4.Пара стрелок, которые позволяют увеличивать или уменьшать значение параметра.
5.Большая площадь экрана отведена под рабочий…
6.Обеспечивает присваивание какому-либо параметру определённого значения ( квадратик с галочкой внутри).
9.Любой файл, обрабатываемый с приложений.
11.Сетевое… - объект, обеспечивающий доступ к сетевым компьютерам и принтерам рабочей группы.
12.Объект, который обеспечивает возможность выбрасывать ненужные файлы.
13.Мой… - объект, открывающий доступ ко всем дисководам и другим устройствам.
15.Название графического изображения, которое соответствует прикладной программе, документу или папке.
16.Папка, служащая для согласования набора данных на 2-х компьютерах.
20.В нижней части экрана расположена ...задач, на которой находится кнопка Пуск

ответы на кроссворд:

По горизонтали: 7.Переключатель. 8.Часы. 10.Окно. 14.Ползунок. 17.Перетаскивание. 18.Мышь. 19.Папка.

По вертикали: 1.Вкладка. 2.Список. 3.Меню. 4.Счётчик. 5.Стол. 6.Флажок. 9.Документ. 11.Окружение. 12.Корзина. 13.Компьютер. 15.Ярлык. 16.Портфель. 20.Панель.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1Сколько раз выполнится тело цикла в следующих фрагментах программ: а) for i:= 1 to 15 do c:=2*i; б) for i:= -4 to 4 do c:=2*i; г) for i:= 4 to 2 do c:=2*i; 2Сколько раз выполнится тело цикла в следующих фрагментах программ: а) x:=10; while x>=0 do x:=x-1; ответ 11 б) x:=0; while x>=0 do x:=x-1; ответ 1 в) x:=0; while x>0 do x:=x-1; ответ 0 3. Определите значение переменной X после выполнения следующего фрагмента программы: x:=1; y:=5; while x+y<10 do begin x:=x+2; y:=y-1; end; 4. Выберите номер фрагмента программы, выполняющего такие же действия, что и приведенный ниже: for i:= 1 to 5 do begin x:=x+2*i; x:=x+1; end; 1) while i< 5 do begin x:=x+2*i; x:=x+1; i:=i+1; end; 2) while i<= 5 do begin x:=x+2*i; x:=x+1; end; 3) i:=1; while i<=5 do begin x:=x+2*i; x:=x+1; i:=i+1; end;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uvarovig
gusrva3001
Андрееевич787
ekasatkina
Shevtsov1818
svetarakityanskaya
Lolira64
sohrokova809
ecocheminnov437
marinakmaa86
puchkovajulia
Railyan
Мусаев Игоревич371
merzlikinairena
verkop9