Задание 2.
1. 6 записей
2. 12 записей
3. 9 записей
4. 5 записей
Задание 3.
ответ: 175 (смотреть фото)
Задание 4.
Для начала необходимо узнать вес изображения:
Расчёт делается по двум формулам. V = i × k, где V - вес изображения, i - глубина цвета, k - количество пикселей в изображении.
V = 2 × (512 × 200) = 204800 байт, тогда 10 изображений будут:
204800 × 10 = 2048000 байт
Переведём все числа к одной единице измерения:
512000 бит/с ÷ 8 = 64000 байт/с
Узнаем количество секунд для передачи изображений:
2048000 ÷ 64000 = 32 секунды
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу на языке Паскаль Пользователь вводит первые 3 члена арифметической прогрессии, программа должна вывести эти 3 и следующие 3 члена арифметической прогрессии. Пример: Ввод: 1 3 5 Вывод: 1 3 5 7 9 11
1)
Объяснение:
Var
a,b,c: integer;
Begin
Writeln('ВВЕДИТЕ ЧИСЛО a ');
Readln(a);
Writeln('ВВЕДИТЕ ЧИСЛО b ');
Readln(b);
Writeln('ВВЕДИТЕ ЧИСЛО c');
Readln(c);
If ((a<b)AND(a<c)) then
Writeln( ' Наименьшее число a = ' , a);
If ((b<a)AND(b<c)) then
Writeln( ' Наименьшее число b = ' , b);
If ((c<a)AND(c<b)) then
Writeln( ' Наименьшее число c = ' , c);
end.
2)
Var
a,b: integer;
Begin
Writeln('ВВЕДИТЕ ЧИСЛО a');
Readln(a);
Writeln('ВВЕДИТЕ ЧИСЛО b');
Readln(b);
If ((a mod 2 = 0 )AND(b mod 2 = 0)) then
Writeln('СУММА ЧЕТНЫХ ЧИСЕЛ = ' , a+b)
Else
Writeln( 'Два числа не являются четными ' );
end.