Petrovich
?>

Задание 1. Приведите общую характеристику языка Паскаль. Какова структура программы на Паскале. Задание 2. Приложена картинка. Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в ЭВМ, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y. Задание 3. Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X = (0, 3; 5; 69; –3; 52; –20; –9; –23; –9; 10; 36; 12; 15; 23; –0, 2; –36; –0, 3; 8; 45; –7) при b = –6 Вычислить произведение и количество элементов, не равных нулю и больших b. Задание 4. Составить программу и блок-схему алгоритма для вычисления площади 5 квадратов со сторонами, изменяющимися от 0 до 15 в цикле. В отчет включить текст программ на Паскале, реакции ЭВМ.

Информатика

Ответы

Эрендженова

№4

Объяснение:

Var x: array [1..15] of integer; p,s: real; i: integer;

begin

 s:=0; p:=1;

 x[1]:=0;  

 x[2]:=5;

 x[3]:=3;

 x[4]:=7;

 x[5]:=14;

 for i:=1 to 15 do begin

   x[i]:=i;

   Writeln('Площадь ',i,sqr(x[i]));

    end;  

end.

Andrei Morozov
//Pascal ABC.NET 3.1 сборка 1219

Var
 k,n,max:integer;

 procedure hase(var k,n,max:integer); //сама последовательность
 begin
  if not(odd(n)) then n:=n div 2 else n:=n*3+1; //условие про чётность
  writeln(n); //вывод нового члена последовательности
  inc(k); //увеличение значения счётчика шагов
  if max<n then max:=n; //поиск вершины
 end;

  procedure start(var k,n,max:integer); //название процедуры намекает
 begin
  readln(n);
  k:=0;
  writeln('Seq:');
  max:=integer.MinValue;
  while n<>1 do
  hase(k,n,max);
  writeln('Шаги:',k);
  writeln('Вершина:',max);
 end;
 begin
 start(k,n,max);
end.
Пример ввода:
6
Пример вывода:
Seq:
3
10
5
16
8
4
2
1
Шаги:8
Вершина:16
sveta740450
Программа:
a = input("Введите текущую координату фигуры(вертикаль): ")
b = input("Введите текущую координату фигуры(горизонталь): ")
c = input("Введите координату для хода(вертикаль): ")
d = input("Введите координату для хода(горизонталь): ")
# Условие
if (a==c) and (b==c):
#Конец условия
     print("Фигура может сделать ход")
else:
     print("Фигура НЕ может сделать ход")
Условия:
а) if (a==c) and (b==c): #ладья
б) if abs(a-c) == abs(b-d): #слон
в) if abs(a-c)==1 or abs(b-d)==1: #король
г) if abs(a-c) == abs(b-d) or a == c or b == d: #ферзь
ж) if((abs(abs(a-c)-2)<0.5) and (abs(abs(b-d)-1)<0.5)
        or (abs(abs(a-c)-1)<0.5) and (abs(abs(b-d)-2.0)<0.5)): #конь

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание 1. Приведите общую характеристику языка Паскаль. Какова структура программы на Паскале. Задание 2. Приложена картинка. Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в ЭВМ, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y. Задание 3. Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X = (0, 3; 5; 69; –3; 52; –20; –9; –23; –9; 10; 36; 12; 15; 23; –0, 2; –36; –0, 3; 8; 45; –7) при b = –6 Вычислить произведение и количество элементов, не равных нулю и больших b. Задание 4. Составить программу и блок-схему алгоритма для вычисления площади 5 квадратов со сторонами, изменяющимися от 0 до 15 в цикле. В отчет включить текст программ на Паскале, реакции ЭВМ.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Марина_Мария
danya1509379
cherkashenko87543
Тамара_Григорьевна897
Решить оба варианта. буду бесконечно ​
oserdyuk41
Васильевий
Sergei Gaishun
Грачева мураховская
alexst123012225
Волков1968
EkaterinaSEMENOV702
korj8
makarov021106
dpodstrel85
andreevaalisa