lepekhov4011
?>

Паскаль, процедуры и функции Составить программу, определяющую, в каком из данных двух чисел больше цифр (создать подпрограмму для вычисления кол-ва цифр в числе

Информатика

Ответы

axo-geo

===== PascalABC.NET =====

function КолЦифр(n: integer): integer;

begin

 (n, Result) := (Abs(n), 0);

 while n > 0 do

 begin

   Inc(Result);

   n := n div 10

 end

end;

begin

 var (a, b) := ReadInteger2('Введите два целых числа:');

 case Sign(КолЦифр(a) - КолЦифр(b)) of

   1: Print('В первом числе больше цифр');

   0: Print('В числах одинаковое количество цифр');

 else

   Print('Во втором числе больше цифр')

 end

end.


Паскаль, процедуры и функции Составить программу, определяющую, в каком из данных двух чисел больше
silicon-films3375

var x1,x2:integer;

function f(x:Integer):Integer ;

var

k:integer;

begin

while x>0 do

begin

x:=x div 10;

k:=k+1;

end;

f:=k;

end;

begin

read(x1,x2);

if f(x1)>f(x2) then

write('В первом числе больше цифр')

else if

f(x2)>f(x1) then

write('В втором числе больше цифр')

else

write('В числах одинаковое количество цифр')

end.

Lyubov214
1. Конституция РФ (ст. 15 официальная публикация законов; ст. 23 неприкосновенность частной жизни, тайна переписки и телефонных переговоров и сообщений; ст. 29 свобода слова и мысли, право на информацию и проч.). 2. Гражданский кодекс РФ (ст. 128 интеллектуальная собственность как объект гражданского права; ст. 150: нематериальные блага: достоинство личности, честь и доброе имя, деловая репутация, неприкосновенность частной жизни, личная и семейная тайна, право авторства и иные личные неимущественные права и другие нематериальные блага; ст. 434 форма договора: договор в письменной форме может быть заключен путем обмена документами посредством электронной связи, позволяющей достоверно установить, что документ исходит от стороны по договору и проч.).3. Уголовный кодекс РФ (ст. 129 клевета; ст. 130 оскорбление, ст. 137 нарушение неприкосновенности частной жизни; ст. 138 нарушение тайны переписки, телефонных переговоров, почтовых, телеграфных или иных сообщений; ст. 146 нарушение авторских и смежных прав; ст. 182 заведомо ложная реклама; ст. 237 сокрытие информации об обстоятельствах, создающих опасность для жизни или здоровья людей; ст. 272 неправомерный доступ к компьютерной информации; ст. 273 создание, использование и распространение вредоносных программ для ЭВМ; ст. 283 разглашение государственной тайны; ст. 303 фальсификация доказательств и проч.).4. Кодекс об административных правонарушениях РФ (глава 13. Административные правонарушения в области связи и информации).5. Закон от 07.02.1992 № 23001 «О защите прав потребителей» (ст. 26.1. Дистанционный продажи товара, под которым в том числе понимается продажа товара через Интернет).6. Закон РФ от 27.12.1991 № 2124I «О средствах массовой информации».7. Федеральный закон от 13.01.1995 № 7ФЗ «О порядке освещения деятельности органов государственной власти в государственных средствах массовой информации».8. Федеральный закон от 13.01.1995 № 7ФЗ «О порядке освещения деятельности органов государственной власти в государственных средствах массовой информации».9. Федеральный закон от 07.07.2003 № 126ФЗ «О связи».
petrova-kate3

Решение. Чтобы разделить 7 яблок на троих, не обязательно разрезать каждое яблоко. Можно сначала каждому раздать по 2 яблока и одно оставшееся разделить на три равные части. Тогда каждый ребенок должен получить 2 + 1/3 яблока. Сумму 2+1/3 принято записывать в виде 2 1/3без знака сложения. Читают, две целых одна третья.

Число 2 1/3 называют смешанным числом, или смешанной дробью, где число 2- целая часть смешанного числа, а число 1/3 – его дробная часть.

Число, состоящее из целой части и дробной части, называется смешанным числом.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль, процедуры и функции Составить программу, определяющую, в каком из данных двух чисел больше цифр (создать подпрограмму для вычисления кол-ва цифр в числе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uvarovig
Voronin-Albertovich
ann-perminova2008
annakuznetsova841
Liliya-buc
verkop9
betepah
Александр Сергей
tigran87-87
Вадимовна
sandovo590
energycomplect5914
Aleksei1463
Blekjek730
Мусаев Игоревич371