galinasemyan689
?>

PYTHON писать через логическую фунццию: Напишите логическую функцию, которая определяет, является ли переданное ей число совершенным, то есть, равно ли оно сумме своих делителей, меньших его самого. Пример: Введите натуральное число: 28 Число 28 совершенное. Пример: Введите натуральное число: 29 Число 29 не совершенное.

Информатика

Ответы

burtsev3339
Посчитаем сколько символов в сообщении: На странице 25 строк, в каждой из которых по 60 символов. Следовательно, на одной странице находится 25 х 60 = 1500 символов. Всего в сообщении 3 страницы, поэтому весь текст состоит из 1500 х 3 = 4500 символов. Определим сколько бит в исходном тексте. 1 байт = 8 бит, следовательно, 1125 байт = 9000 бит. В тексте, занимающем 9000 бит 4500 символов, следовательно, на 1 символ приходится 9000 : 4500 = 2 бита. При х битного бинарного кода можно закодировать 2 ^ 2 = 4 комбинации. ответ: в искомом алфавите 4 символа.
happych551
var    
        A, num: array[1..999] of integer;
        k, kk: integer;

function SN(c: integer): boolean;
begin
        for var j := 2 to 9 do begin
            if c mod num[j] <> 0 then
                inc(k);
        end;
        if k = 8 then begin
            SN := true;
            inc(kk);
        end else if k <> 8 then
             SN := false;
        k := 0;
end;

begin
    for var i := 2 to 9 do
         num[i] := i;
    for var i := 1 to 7 do begin
         A[i] := random(2, 200);
        writeln(A[i] + ' ');
        writeln(SN(A[i]));
    end;
    writeln(kk);
end.

Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д
Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON писать через логическую фунццию: Напишите логическую функцию, которая определяет, является ли переданное ей число совершенным, то есть, равно ли оно сумме своих делителей, меньших его самого. Пример: Введите натуральное число: 28 Число 28 совершенное. Пример: Введите натуральное число: 29 Число 29 не совершенное.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ortopediya
yna21289
f-d-a-14
tolyan791
ooo-krasa
andrew55588201824
Gor Anatolevich
samiramoskva
anikamalish
NatalyaAlekseevich1644
gsktae7
leonid-adv70
Дмитриевич Бирковская69
fedchenkoofficial
katya860531