Татьяна902
?>

В ЧЕМ ПРОБЛЕМА?МНЕ НУЖНО РЕШИТЬ ВОТ ЭТУ ЗАДАЧУ ТОЛЬКО ЦИКЛАМИ И ФУНКЦИЕЙ: Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9 Используйте функцию для вычисления суммы цифр числа. program q; function dl(n:integer):integer; var b, r:integer; begin b:=0; while n<>0 do begin b:=b + n mod 10; n:=n div 10; end; dl:=b; end; var b, r, n, f, a, c, h, j, k, u:integer; begin readln(n); for f:=0 to n do begin c := dl(f); for a:=2 to 9 do if c= dl(a* f) then writeln(c); end; end.

Информатика

Ответы

violetta152028
#include "stdafx.h"
#include "iostream"    //Подключаем библиотеку ввода вывода
#include "math.h"      //библиотека математических функций

#include <windows.h>

using namespace std;   //подключение пространства имён std - открывает
//доступ к cin и cout из библиотеки iostream

int main()   //начало программы
{
SetConsoleCP(1251);   //если будешь компилировать     SetConsoleOutputCP(1251);   //то это для подключения русского языка в консоли

float x, y, z;   //объявление вещественных переменных
cout<<"Введите значение X";   //вывод строки
cin>>x;   //вводим число
y=sqrt(x);   //считаем y
if ((x<3) || (x>8))    //условие. если (x<3 или x>8)  
z=x*y; //есил истино z=x*y
else z=x+y; //иначе z=x+y

cout<<"z= "<<z;  //вывод результата

cout<<"Для завершения программы нажмите любую клавишу...";
cin.get();
cin.get();
return 0;
}
ASRodichev
Технология создания электронных таблиц в MS Excel Цель: изучить инструменты ввода, редактирования, форматирования и обработки числовых данных в электронной таблице. Изучив данную тему, студент должен: иметь представление о; • технологиях обработки числовых данных в электронных таблицах; знать: • инструменты ввода, редактирования, форматирования и обработки числовых данных в электронной таблице; • принципы работы Мастера диаграмм; уметь: • форматировать ячейки таблицы; • выполнять простейшие вычисления и использовать элементарные функции в расчетах; • использовать относительную и абсолютную адресацию; • выполнять построение и форматирование диаграмм; • установить защиту рабочей книги; владеть навыками: • обработки информации в электронных таблицах; • построения различного вида диаграмм (графиков, гистограмм и др.) с мастера диаграмм Excel.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В ЧЕМ ПРОБЛЕМА?МНЕ НУЖНО РЕШИТЬ ВОТ ЭТУ ЗАДАЧУ ТОЛЬКО ЦИКЛАМИ И ФУНКЦИЕЙ: Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9 Используйте функцию для вычисления суммы цифр числа. program q; function dl(n:integer):integer; var b, r:integer; begin b:=0; while n<>0 do begin b:=b + n mod 10; n:=n div 10; end; dl:=b; end; var b, r, n, f, a, c, h, j, k, u:integer; begin readln(n); for f:=0 to n do begin c := dl(f); for a:=2 to 9 do if c= dl(a* f) then writeln(c); end; end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kol-nat26
nat63nesnova5
rashad8985
arina2403423
oslopovavera
mdsazonovatv1173
modellisimo-a
mnogomams47
nnbeyo
Sergei
Ольга Сергей1822
Надежда-Алексеевна82
Анатольевна824
Avolohova
anna-leonova