Tsevich333639
?>

записать программу на паскале для робота Task сс9. Я его решил, но только строго для 9, а мне нужно для бесконечного поля.​

Информатика

Ответы

Koshovkina1721
Var
  m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
  s:real;
  a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
  begin
  writeln('Вводите элементы строки ',i,' по одному');
  for j:=1 to n do    readln(a[i,j]);
  end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
  for j:=1 to n do
    begin
    if a[i,j]<min then
      begin
      min:=a[i,j];
      imn:=i;
      jmn:=j;
      end;
    if a[i,j]>max then
      begin
      max:=a[i,j];
      imx:=i;
      jmx:=j;
      end;
    end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
  begin
  for j:=1 to n do    write(a[i,j]:5);
  writeln;
  end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
  if a[i,j]<0 then
    begin
    s:=s+a[i,j];
    k:=k+1;
    end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);  
end. 
Leon-12

Код + скриншот (код и вывод компилятора). Строки с #... - комментарии. Если хотите, что бы показывался весь процесс работы программы - уберите только "#". Если не нужно - можете удалить строки с #... (не обязательно):

N = int(input("N = "))

fact_N = 1

for i in range(1,N+1):

   fact_N *= i

#print("Factorial N = ",fact_N)

count_dividers = 0

for divider in range(1,fact_N+1):

   if (fact_N % divider == 0):

       count_dividers += 1

#        print(count_dividers,"divider = ",divider)

print("Amount of dividers for '",N,"' - ",count_dividers)


Напишите программу на питоне Делители факториала По заданному натуральному числу N необходимо вычисл

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

записать программу на паскале для робота Task сс9. Я его решил, но только строго для 9, а мне нужно для бесконечного поля.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nelli-bi6
Марюк-Мубариз
zotovinbox468
Vladimirovich351
dima0218687
Shago
npdialog66
Анатольевна824
Gesper63
guzelda19904850
Андрей-Викторовна1910
mekap22044
Станислав Валерий1696
optima3559
Nikolaevich824