?>
Написать программу и составить блок-схему к следующим задачам:1) Даны два неотрицательных числа. Найти их среднее геометрическое, результат вывести на экранНеобходимо найти в Интернете, что такое среднее геометрическое, вспомнить как записывается квадратный корень в программе) 2)Даны катеты прямоугольного треугольника. Найти его гипотенузу, периметр и площадь. Результат вывести на экран
Ответы
i, j, k : word;
f : boolean;
function isSpace(ch : char) : boolean;
begin isSpace := false;
if ch = ' ' then isSpace := true;
end;
begin f := false;
repeat j := 0;
writeln('введите строку, состоящую из 2 слов');
readln(s);
for i := 1 to length(s) do
if isSpace(s[i]) then
begin
inc(j);
k := i; end;
if j =1 then f := true;
until f;
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1));
end.
недавно такую писала :)