Ka2ffka141
?>

Напишите программу, определяющую по координатам точки, в какой четверти системы координат она находится.​

Информатика

Ответы

vallium8354

Объяснение: Для решения задачи нам понадобиться оператор if. В самой задаче мы будем использовать всего две переменные , которые у нас будут хранить координаты.

1

2

3

4

5

uses crt ;

var

x, y : integer ;

begin

end.

Мы объявили две переменные. Теперь попросим пользователя ввести значения этих переменных :

1

2

write('Введите x : '); readln(x);

write('Введите y : '); readln(y);

И после того как у нас в переменных есть какие то числа , мы пишем условие :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

write ('Номер четверти координатной плоскости: ');

if (x > 0) and (y > 0) then

writeln ('I')

else

if (x < 0) and (y > 0) then

writeln ('II')

else

if (x < 0) and (y < 0) then

writeln ('III')

else

if (x > 0) and (y < 0) then

writeln ('IV')

else

writeln ('-. Точка лежит на оси.');

Тут уже идет больше знание математики , ну и конечно же умение писать вложенные условия .

Весь код программы :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

uses crt ;

var

x, y : integer ;

begin

clrscr; {очищаем экран}

write('Введите x : '); readln(x);

write('Введите y : '); readln(y);

write ('Номер четверти координатной плоскости: ');

if (x > 0) and (y > 0) then

writeln ('I')

else

if (x < 0) and (y > 0) then

writeln ('II')

else

if (x < 0) and (y < 0) then

writeln ('III')

else

if (x > 0) and (y < 0) then

writeln ('IV')

else

writeln ('-. Точка лежит на оси.');

readln; {чтобы программа не закрывалась}

end.

Вот результат :

ris11

arhangel1055
Объявим нужные переменные
Нам потребуется sum(сумма), average(ср. арифм), i(для цикла), n(кол-во чисел), x(введенное значение), count(счетчик нечетных)
Присваиваем переменной n(кол-во чисел) нужное значение.
Обнуляем summ и count
Организовываем ввод чисел с клавиатуры через цикл от 0 до n
Внутри цикла делаем проверку на четность, примерно так:
if x mod 2 = 1 then (mod 2 обозначает остаток от деление на 2)
А здесь увеличиваем переменную sum = sum + x
И счетчик count = count + 1

Теперь после того как все итерации пройдены
Переменная sum хранит значение суммы нечетных чисел.
А переменную average надо разделить на count. average = average / count
Так мы получим ср. арифметическое для всех нечетных чисел.

Выводим значение sum и average.
kristinagaspa62
//PascalABC
//NaaMan
var
    N, sum, num, i : integer;
    A : array[1..10000] of integer;
    SA : real;
begin
    write('Укажите, сколько будет чисел > ');
    readln(N);
    write('Вводите элементы массива > ');
    // Обнуляем сумму
    sum := 0;
    // и количество искомых элементов
    num := 0;
    // Ввод элементов массива с одновременным подсчетом
    for i := 1 to N do begin
        // Ввод
        readln(A[i]);
        write('Ещё > ');
        // Если введённое нечётное, то
        if A[i] mod 2 = 1 then begin
            // добавляем к сумме
            sum := sum + A[i];
            // и считаем их количество
            num := num + 1;
        end;
        // Это среднее арифметическое
        SA := sum / num;
    end;
       
    writeln('Сумма элементов ', sum);
    writeln('Среднее арифметическое ', SA);
end.

Составьте программу , которая считывает с клавиатуры n чисел и находит сумму и среднее арифметическо

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, определяющую по координатам точки, в какой четверти системы координат она находится.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

v89167233402
kristi-a-90
o-lala88387
nikitamihailov22095010
ver2bit
prianik6
Aleks0091
Александра-Андрей909
tatasi
Ryadovboxing23
Nikolaevich-Svetlana388
Романенко
татьяна1245
Karpova
krylova-natali