svetkinm158
?>

Написать программу в PascalABC: Определить есть ли среди чисел х, у, z, хотя бы одно отрицательное, если среди них есть отрицательные то посчитать их кол-во

Информатика

Ответы

Nonstop788848

begin

 var count := 0;

 var num := 0;

 repeat

   var a := ReadInteger;

   Inc(num);

   if a < 0 then

     Inc(count);

 until num = 3;

 Println('Количество отрицательных: ', count);

end.

anitanemtsewa

главное меню  расположено в верхней строке окна заключает в себе все возможности программы, рассортированные по более или менее однотипным . для входа в меню необходимо либо воспользоваться мышью, либо нажать f10, затем перемещаться по меню с клавиш курсором. покинуть меню можно, нажав клавишу esc.

панели  – две равноправные таблицы, занимающие основную часть окна. внутри панелей может отображаться различная информация. одна из панелей является активной (на ней находится курсор и заголовок панели подсвечен), другая панель – пассивная. смена активное панели достигается нажатием tab или щелчком мыши в любой части панели. при этом курсор перемещается с одной панели на другуюкомандная строкаменю функциональных клавиш  запуск команд ms-dos из командной строкипросмотр содержимого файларедактирование файла встроенным редактором.копирование файла или каталогапереименование и перенос файла или каталога.создание нового каталогаудаление файлов и каталоговработа с группами файлов и каталогов

Sergeevich-Novikov
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var b:array[1..6,1..6] of integer:=(
    (19,21,23,25,27,29),(57,59,61,63,65,31),
    (55,81,83,85,67,33),(53,79,89,87,69,35),
    (51,77,75,73,71,37),(49,47,45,43,41,39));
  var a:array[1..6,1..6] of integer;  
  var k:=2;
  var k0,k1:integer;
  for var i:=1 to 6 do begin
    for var j:=1 to 6 do Print(b[i,j]);
    Writeln
    end;
  Writeln;
  repeat
    k0:=0;
    k1:=0;
    Writeln('k=',k);
    for var i:=1 to 6 do begin
      for var j:=1 to 6 do begin
        if (b[i,j] mod k) mod 2=0 then
          begin a[i,j]:=1; Inc(k1) end
        else begin a[i,j]:=0; Inc(k0) end;
        Print(a[i,j])
        end;
      Writeln
      end;
    Writeln('k0=',k0,', k1=',k1);
    if k0<>k1 then Inc(k)
  until k0=k1;
  Writeln(NewLine,'k=',k)
end.

Решение
19 21 23 25 27 29
57 59 61 63 65 31
55 81 83 85 67 33
53 79 89 87 69 35
51 77 75 73 71 37
49 47 45 43 41 39

k=2
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=3
0 1 1 0 1 1
1 1 0 1 1 0
0 1 1 0 0 1
1 0 1 1 1 1
1 1 1 0 1 0
0 1 1 0 1 1
k0=12, k1=24
k=4
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=5
1 0 0 1 1 1
1 1 0 0 1 0
1 0 0 1 1 0
0 1 1 1 1 1
0 1 1 0 0 1
1 1 1 0 0 1
k0=14, k1=22
k=6
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=7
0 1 1 1 1 0
0 0 0 1 1 0
1 1 1 0 1 0
1 1 0 0 1 1
1 1 0 0 0 1
1 0 0 0 1 1
k0=16, k1=20
k=8
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=9
0 0 0 0 1 1
0 0 0 1 1 1
0 1 1 1 1 1
1 0 1 1 1 1
1 0 0 0 1 0
1 1 1 0 0 0
k0=16, k1=20
k=10
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=11
1 1 0 0 0 0
1 1 1 1 1 0
1 1 1 1 0 1
0 1 0 1 0 1
0 1 0 0 0 1
0 0 0 1 1 1
k0=16, k1=20
k=12
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
k0=36, k1=0
k=13
1 1 1 1 0 0
0 0 0 0 1 0
0 0 0 0 1 0
0 0 0 0 1 0
1 1 1 1 1 0
1 1 1 1 1 1
k0=18, k1=18

k=13

ответ: 13

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в PascalABC: Определить есть ли среди чисел х, у, z, хотя бы одно отрицательное, если среди них есть отрицательные то посчитать их кол-во
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Аверьянова
MelnikovaIvanovna
Immortal3331
ViktorovnaLarin
Vetroff-11
strelnikov-aa
vasenkova1981
eurostom
Хохлов
Azarova Anastasiya1707
Nadezhda
rikki07834591
Yekaterina
alvs9
pimenov5