sashakrotova943
?>

Составьте программу решающую следующую задачу дано трехзначное число в нём зачеркнули первую цифру слева и приписали её справа вывести полученное число ввод 452 вывод 524

Информатика

Ответы

notka19746

begin

var x:=ReadString('Введите число: ');

Println(x, ' --- ', x[2]+x[3]+x[1]);

end.

Как вариант)

oksanashabanovadc3197

PascalABC.NET

begin

 var n := ReadInteger;

 Print(10 * (n mod 100) + n div 100)

end.

dailyan539
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
milenaochirova01017424
Const
  n = 5;//Емкость памяти типа "кольцо"

type
  Ring = array[1..n] of integer;

var
  ir: integer;
  R: Ring;

procedure Add2Ring(a: integer);
  // Добавляет в кольцо очередной элемент
begin
  if ir = n then ir := 1
  else ir := ir + 1;
  R[ir] := a
end;

var
  i, S, d: integer;
  P: longint;

begin
  S := 0;
  ir:=0;
  writeln('Вводите числа, 0 - конец ввода');
  for i := 1 to n do
  begin
    readln(d);
    S := S + d;
    Add2Ring(d)
  end;
  repeat
    readln(d);
    if d <> 0 then Add2Ring(d);
  until d = 0;
  P := 1;
  for i := 1 to n do P := P * R[i];
  writeln('Сумма первых ', n, ' чисел: ', S, ', произведение последних: ', P)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу решающую следующую задачу дано трехзначное число в нём зачеркнули первую цифру слева и приписали её справа вывести полученное число ввод 452 вывод 524
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julya847
sevro3038
frolevgevg6420
Maly01984489
Абдулганиева Сергей
ekvld708
tooltechnic
Aksinya1036
Corneewan
avdushinalizza1
vasenkova1981
elegiy
yuip2008
eisakov86
pavpe4198