vovkiv7864
?>

Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++

Информатика

Ответы

eremenkou

#include <iostream>

using namespace std;

int

main ()

{

 int n, i, t = 1, m, a[100]; \\ можно поставить свои ограничения;

 cin >> n;

 for (i = 0; i < n; i++)

   cin >> a[i];

 m = a[0] - 1;

 for (i = 0; i < n; i++)

   {

     if (a[i] > m)

{

  m = a[i];

  t = 0;

};

     if (a[i] == m)

t++;

   };

 cout << t;

 return 0;

}

izumrud153
Клавиши клавиатуры, в зависимости от их назначения и расположения, можно поделить на группы: -Алфавитно-цифровые; -Функциональные; -Блок дополнительных клавиш (цифровая панель); -Клавиши управления курсором; -Служебные (клавиши управления). -Алфавитно-цифровые клавиши. Назначение: ввод букв, цифр, знаков препинания и других специальных знаков. В эту категорию также относится клавиша SPACE (ПРОБЕЛ). -Функциональные клавиши Сюда относят клавиши F1-F12. За данными клавишами нет постоянных закрепленных функций (исключением является только клавиша F1, которая используется для получения справки). Эти клавиши, как правило, программируются уже пользователем для каждой программы отдельно. -Блок дополнительных клавиш (цифровая панель) Повторяют действие цифровых и некоторых знаковых клавиш основной панели Даная панель может использоваться в двух режимах: * Ввода цифр; * Управления курсором. Переключения режимов осуществляется клавишей NUM LOCK -Клавиши управления курсором Курсор — экранный указатель, который показывает место ввода следующего символа (для текста) или текущую позицию (точку), к которой будет применяться действие мыши. Клавиши со стрелками служат для перемещения курсора на одну позицию по экрану монитора в соответствии с направлением. Клавиши PAGEUP и PAGEDOWN3 переводят курсор на одну страницу вверх и вниз соответственно, а клавиши HOME и END переводят курсор в начало и конец текущей строки. Клавиша INSERT переключает режима ввода данных: вставка и замена ( в режиме вставки новые знаки вводятся без замены существующих символов, а в режиме замены — заменяют). Клавиша DELETE удаляет знаки, которые находятся справа от текущего положения курсора, а клавиша BACKSPACE удаляет знаки, которые находятся слева от текущего положения курсора.
Геннадьевна_Петр

1. Текстовый редактор. Так как текст программы записывается с ключевых слов, обычно происходящих от слов английского языка, и набора стандартных символов для записи всевозможных операций, то формировать этот текст можно в любом редакторе, получая в итоге текстовый файл с исходным текстом программы. Лучше использовать специализированные редакторы, которые ориентированы на конкретный язык программирования и позволяют в процессе ввода текста выделять ключевые слова и идентификаторы разными цветами и шрифтами. Подобные редакторы созданы для всех популярных языков и дополнительно могут автоматически проверять правильность синтаксиса программы непосредственно во время ее ввода.

2. Исходный текст с программы-компилятора переводится в машинный код. Исходный текст программы состоит, как правило, из нескольких модулей (файлов с исходными текстами). Каждый модуль компилируется в отдельный файл с объектным кодом, которые затем требуется объединить в одно целое. Кроме того, системы программирования, как правило, включают в себя библиотеки стандартных подпрограмм (имеют расширение .LIB). Стандартные подпрограммы имеют единую форму обращения, что создает возможности автоматического включения таких подпрограмм в вызывающую программу и настройки их параметров.

3. Объектный код модулей и подключенные к нему стандартные функции обрабатывает специальная программа – редактор связей. Данная программа объединяет объектные коды с учетом требований операционной системы и формирует на выходе работо приложение – исполнимый код для конкретной платформы. Исполнимый код это законченная программа, которую можно запустить на любом компьютер, где установлена операционная система, для которой эта программа создавалась. Как правило, итоговый файл имеет расширение .exe или .com.

4. В современных системах программирования имеется еще один компонент – отладчик, который позволяет анализировать работу программы во время ее исполнения. С его можно последовательно выполнять отдельные операторы исходного текста последовательно, наблюдая при этом, как меняются значения различных переменных.

5. В последние несколько лет в программировании (особенно для операционной среды Windows) наметился так называемый визуальный подход. Этот процесс автоматизирован в средах быстрого проектирования. При этом используются готовые визуальные компоненты, свойства и поведение которых настраиваются с специальных редакторов. Таким образом, происходит переход от языков программирования системного уровня к языкам сценариев.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dodkhobekovich1683
zu87zu87
ambstroy
alexeylipatov
Vitalevna
ЕвгенияСергеевна
Galina_Yurevna
bondarenkoss
info6
vse-v-sad-sdesign
mariavayda88734
Larax0819
corneewa20096
mariapronina720126
aistenok-28