sklad2445
?>

Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляет А^N без использования операции возведения в степень.

Информатика

Ответы

Ulianev77

a = int(input())

n = int(input())

a1 = a

for k in range (n - 1) :

   a *= a1

print (a)

Объяснение:

Мы вводим два числа и начинаем цикл While, в котором мы каждый раз когда делаем возведение в степень (умножаем число А на самого себя) уменьшаем число N (значащее степень, в которую надо возвести число)

Прикладываю базовые тесты:


Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляе
arturusinsk5
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.
volkovaoksana19806037
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляет А^N без использования операции возведения в степень.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annaan-dr582
LYuBOV
Peshkov
artem032100
pravovoimeridian
sveta740450
oksanashabanovadc3197
expozition
Sergei_Olga658
alenchik19938823
Mexx9050
snopovajulia
zrv85
yanva
kabinet17