Aleksandrova Zhanna1250
?>

Составьте блок-схему и напишите программу к задаче: найти периметр треугольника со сторонами a, b, c​

Информатика

Ответы

Yekaterina358

program ExampleN;

uses Math;   // объявление математических функций для вашей версии паскаля

var

 a, b, d, s, y1, y2, x: Double;

begin

 Write ('Введете границы отрезка: ');

 ReadLn (a, b);

 s := 0;

 d := (b - a) / 10;             // длина 1/10 отрезка

 x := a + d / 2;                // начальное значение Х = левая граница + половина отрезка (середина основания)

 while x < b do begin           // цикл по всей длине отрезка

   y1 := Sqr (x);

   y2 := 5 + x / 2;

   s := s + Abs (y1 - y2) * d;  // расчет площади прямоугольника и суммирование

   x := x + d;                  // увеличение Х на 1/10 отрезка

 end;

 WriteLn ('Площадь = ', s :20 :10);

 ReadLn;

end.

qwert28027170

bank_ques = {}

#Создание вопросов:

# bank_ques["сам вопрос"'] = "ответ на него", вопрос и ответ в виде строки, даже если это число

bank_ques["2*2"] = "4"

bank_ques["3*3"] = "9"

bank_ques["4*4"] = "16"

bank_ques["5*5"] = "25"

bank_ques["6*6"] = "36"

#Вопросов может быть неограниченное количество

# Также генерировать вопросы можно как в самом коде, так и сделать в цикле, но тут уже как хотите

for question in bank_ques:

   print(question)

   answer = input("ответ: ")

   if answer == bank_ques[question]:

       print("правильно")

   else:

       print("ответ неверный")

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте блок-схему и напишите программу к задаче: найти периметр треугольника со сторонами a, b, c​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kapi30
pizzaverona
Вячеслав
tatianamatsimoh
Irina
luxoutlet
Kochereva-Sergei
Merkuloff78
JisesLove19955
egcuzn86
varvara82193
pechyclava
kolgatin69
vsbrelok
marusyamr