Нана_Елена
?>

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 30: #include using namespace std; int F(int x) { if (x < 3) return 1; else return 2 * F(x - 1) + F(x - 2); } int main() { int i, k; i = 15; cin >> k; while (i > 0 && F(i) > k) i = i - 1; cout << i; } var i, k: integer; function F(x:integer):integer; begin if x < 3 then F:= 1 else F:= 2*F(x-1) + F(x-2); end; begin i := 15; readln(K); while (i > 0) and (F(i) > K) do i:=i-1; writeln(i); end.

Информатика

Ответы

namik120939

24

Объяснение:

var

i,j,k: integer;

function F(x:integer):integer;

begin if x < 3 then

F:= 1

else F:= 2*F(x-1) + F(x-2);

end;

begin

for k:=15 to 50 do

begin

i := 15;

while (i > 0) and (F(i) > K) do

i:=i-1;

write(i,' ');

end;

end.

jgaishun756
1) 56(10) ⇒ х(2)
Для перевода целого числа из десятичной системы в двоичную выполняем его целочисленное деление на два с сохранением остатка. Если частное больше единицы, делим его на два, снова сохраняем остаток и т.д. Как только частное станет равным 1 или 0, записываем его, а затем приписываем к нему слева остатки в порядке, обратном их получению.
56 / 2 = 28 (остаток 0)
28 / 2 - 14 (остаток 0)
14 / 2 = 7 (остаток 0)
7 / 2 = 3 (остаток 1)
3 / 2 = 1 (остаток 1)
Записываем результат. 56(10) = 111000(2)

Переводы в десятичную систему счисления выполняются путем записи числа в расширенном виде по основанию системы счисления, в которой представлено число. А далее операции выполняются в десятичной системе.
2) \ 121_8=1\times8^2+2\times8^1+1\times8^0=64+16+1=81_{10} \\ 6) \ 11001_2=1\times2^4+1\times2^3+0\times2^2+0\times2^1+1\times2^0= \\ 16+8+1=25_{10}

Переводы чисел между системами счисления по основаниям, кратным степеням двойки (2,4,8,16) выполняется через двоичную систему счисления, как через промежуточную. Например, при переходе от восьмеричной системы к шестнадцатиричной, мы учитываем, что 8=2^3, каждую восьмеричную цифру заменяем тремя двоичными (триадой) и получаем двоичное число. А затем, зная что 16=2^4, мы группируем двоичные разряды справа налево по четыре, получая тетрады. И, наконец, каждую тетраду мы заменяем соответствующей шестнадцатиричной цифрой. Описывать этот процесс долго, а перевод делается быстро.
3) 77(8) = 111 111(2) = 11 1111(2) = 3F(16)
4) 57(8) = 101 111(2) = 101111(2)
5) 9A(16) = 1001 1010(2) = 10011010(2)
7) 10011(2) = 010 011(2) = 23(8)
8) 101011(2) = 0010 1011(2) = 2B(16)
os7960
Для мене зручна клавіатура це рівно розприділені функціональні клавіші на обидві сторони клавіатури для швидшої роботи з ПК. Розкладку клавіатури я вважаю залишити такою ж, бо вже звик до такої і вона мені найбільш зручна. Хотілось би, щоб розміщення клавіш було рельєфним для зручнішого і швидшого друку тексту. Мала ложе під зап'ястя щоб руки менш втомлювались. І мала сантиметровий підйом над столом, щоб у випадку потрапляння рідини на стіл не була пошкоджена. Дуже зручно було б мати USB порт для зручної роботи з флешками і мала додаткові регулюючі софт клавіші при натисканні яких вмикалась вибрана програма. Ось це була б найзручніша клавіатура для мене.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 30: #include using namespace std; int F(int x) { if (x < 3) return 1; else return 2 * F(x - 1) + F(x - 2); } int main() { int i, k; i = 15; cin >> k; while (i > 0 && F(i) > k) i = i - 1; cout << i; } var i, k: integer; function F(x:integer):integer; begin if x < 3 then F:= 1 else F:= 2*F(x-1) + F(x-2); end; begin i := 15; readln(K); while (i > 0) and (F(i) > K) do i:=i-1; writeln(i); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайловна991
mukbidc
best00
ВостриковаСтародубцева1980
sport2293032
okutihamv
ntinyakova
лукашова940
nsmirnova
Popova-Erikhovich
Пономаренко
Владимирович
Vladimirovna1370
nordwokintos4
Наталья Юрьевич1228