oskina3
?>

Написать программу в C++ Задача. Даны три действительных числа X, Y, Z. Если они попарно различны и их полусумма больше единицы, то заменить меньшее из X и Z полусуммой двух оставшихся значений; в противном случае заменить меньшее из X, Y, Z наибольшим из них. ;)

Информатика

Ответы

goldglobustour725

#include <iostream>

int main()  

{

   double x, y, z;

   double min, max;

   std::cin >> x;

   std::cin >> y;

   std::cin >> z;

   if (((x != y) && (x != z) && (y != z))

       &&

       ((x + y + z) / 2 > 1))

   {

       if (x < z)  

           x = (z + y) / 2;

       else  

           z = (x + y) / 2;

   }

   else

   {

       min = x, max = x;

       if (y < x) min = y;

       if (z < x) min = z;

       if (y > x) max = y;

       if (z > x) max = z;

       if (x == min)  

       {

           if (y == max) x = y;

           else if (z == max) x = z;

       }

       else if (y == min)

       {

           if (x == max) y = x;

           else if (z == max) y = z;

       }

       else if (z == min)

       {

           if (x == max) z = x;

           else if (y == max) z = y;

       }

   }

   return 0;

}

ivanov568
Вопрос с подвохом, пропускная меряется не от возможной передачи на стороне провайдера или пользователя, а от версии протокола 2СH (2 цэ-аш). Рассмотрим 2 последние версии. Протокол 2015 года поддерживал пропускную вплоть до 20 MB/WEBM. Стандарт нового протокола поразили многих экспертов, скорость была снижена вдвое. Но сделано это было в связи с отказом многих производителей сетевого оборудования устанавливать расширяющие микросхемы PassCODE для поддержки тех самых 20 MB/WEBM. Может в будущем, с большим распространением PassCODE пропускную поднимут, но пока приходится с этими ограничениями смирится и перекодировать WEBM что несомненно, приведет к ухудшению их качества. 
Sergei248
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в C++ Задача. Даны три действительных числа X, Y, Z. Если они попарно различны и их полусумма больше единицы, то заменить меньшее из X и Z полусуммой двух оставшихся значений; в противном случае заменить меньшее из X, Y, Z наибольшим из них. ;)
Ваше имя (никнейм)*
Email*
Комментарий*