aaltuxova16
?>

1.Написать программу, которая описывает как вещественные переменные и вводит с клавиатуры скорость (v) и время (t) равномерного движения тела, рассчитывает и выводит на экран значение расстояния (s), пройденного телом за это время. Составить алгоритм. Вычисления выполнить с 3-мя наборами данных. 2.Составить алгоритм и программу вычисления значения выражения y =4a/(a-b)+√(а+с) по заданным a, b, c. Вычисления выполнить с 3-мя наборами данных.

Информатика

Ответы

bike-garage8

PascalABC.Net

begin

 var (v, t) := ReadReal2;

 Println('S:=', v * t);

 //Задача 2

 var (a, b, c) := ReadReal3;

 Println('Y:=', 4 * a / (A - b) + Sqrt(A + c));

end.

reception
//PascalABC.Net 3.1 сборка 1200
uses System;

begin
    var Replace4to16 := new Dictionary<string, string>();
    Replace4to16.Add('00', '0');
    Replace4to16.Add('01', '1');
    Replace4to16.Add('02', '2');
    Replace4to16.Add('03', '3');
    Replace4to16.Add('10', '4');
    Replace4to16.Add('11', '5');
    Replace4to16.Add('12', '6');
    Replace4to16.Add('13', '7');
    Replace4to16.Add('20', '8');
    Replace4to16.Add('21', '9');
    Replace4to16.Add('22', 'a');
    Replace4to16.Add('23', 'b');
    Replace4to16.Add('30', 'c');
    Replace4to16.Add('31', 'd');
    Replace4to16.Add('32', 'e');
    Replace4to16.Add('33', 'f');
    
    var n4 := ReadString('a_4 = ');
    if n4.Length mod 2 = 1 then n4 := '0' + n4;
    
    var n16 := '';
    for var i := 0 to n4.Length div 2 - 1 do
        if Replace4to16.ContainsKey(n4.Substring(2 * i, 2)) then
            n16 += Replace4to16[n4.Substring(2 * i, 2)]
        else writeln('Неверные знаки "', n4.Substring(2 * i, 2), '" в числе');
    
    writeln(n16);
end.
dmdlir
1. Наука, изучающая законы и формы мышления, называется:
Г) логика
 
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется:
В) высказывание
 
3. Константа, которая обозначается «1» в алгебре логики называется: 
В) истина
 
4. Какое из следующих высказываний являются истинным? 
В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
 
5. Объединение двух высказываний в одно с союза «и» называется: 
Б) конъюнкция
 
6. Чему равно значение логического выражения (1v1)^(1v0)? 
А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
 
7. Что такое логика?
B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
 
8. Логической операцией не является:
A) логическое деление
 
9. Объединение двух высказываний в одно с оборота «если..., то..» называется:
Г) импликация
 
10. Таблица, содержащая все возможные значения логического выражения, называется:
Б) таблица истинности
 
11. Даны три высказывания: 
А = (Наступила осень)
В = (Мы учимся в колледже)
С = (Мы решаем контрольную работу)
Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу» 
ABC
 
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции:
Х=А+ВС
В ответе выписать комбинации А, В, С при которых Х – ложно.
Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии".
Таблица истинности:
A B C X
0 0 0 0
0 0 1 0
0 1 0 0 – случай из примера
0 1 1 1
1 0 0 1
1 0 1 1
1 1 0 1
1 1 1 1
X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.Написать программу, которая описывает как вещественные переменные и вводит с клавиатуры скорость (v) и время (t) равномерного движения тела, рассчитывает и выводит на экран значение расстояния (s), пройденного телом за это время. Составить алгоритм. Вычисления выполнить с 3-мя наборами данных. 2.Составить алгоритм и программу вычисления значения выражения y =4a/(a-b)+√(а+с) по заданным a, b, c. Вычисления выполнить с 3-мя наборами данных.
Ваше имя (никнейм)*
Email*
Комментарий*