НиколаевнаФ
?>

Написать программу, которая вводит число. Если число двузначное, то нужно найти сумму цифр в числе. Если число трехзначное – произвести произведение цифр числа. Если число четырехзначное – найти среднее арифметическое цифр этого числа. Если число иное – вывести запись «Введите 2-х, 3-х или 4-х значное число».

Информатика

Ответы

vikashop269
var  x, n: integer;  n1: real; begin  Writeln('Введите число: ');  Read(x);  if (x > 9) and (x < 100) then  begin    n := (x div 10) + (x mod 10);    Writeln('Сумма цифр равна: ', n);  end;  if (x > 99) and (x < 1000) then  begin    n := (x div 100) * ((x div 10) mod 10) * (x mod 10);    Writeln('Произведение цифр равно: ', n);  end;  if (x > 999) and (x < 10000) then  begin    n := x div 1000 + (x div 100) mod 10 + (x div 10) mod 10 + x mod 10;    n1 := n / 4;    Writeln('Среднее арифметическое равно: ', n1);  end;  if x > 9999 then  begin    Writeln('Введите 2-х, 3-х или 4-х значное число');  end; end.
Виктория-Марина626
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! begin   writeln('*** исходный массив ***');   var a: =matrrandom(2,4,-10,30);   a.println(4); writeln(4*a.colcount*'-');   writeln('п = ',a.elementsbyrow.where(t-> t.between(1,19))           .aggregate(1,(x,y)-> x*y)) end. пример *** исходный массив ***   24  16  22  12     2    5    1    8 п = 15360
mahalama7359
Открываем "Мохнатую азбуку" Бориса Заходера и читаем названия животных на все буквы алфавита.

a. Слово ёж можно зашифровать рисунками жирафа и зебры.

b. Алгоритм расшифровки.
1) смотрим картинку животного.
2) берём его первую букву.
3) берём предыдущую букву.

c. Расшифровать сообщение, которого нет, очень трудно.

d. Нет животных на такие буквы:
Й, Ь, Ы, Ъ, Ю.
Интересная ситуация с буквой Ю. Вот стихи:
Это Южный Ктототам.
Я его придумал сам.
Я вам честно говорю:
Зверя нет на букву Ю!
В одной книге я видел иллюстрацию к этой букве. В качестве Южного Ктототама неожиданно был нарисован... негр.
Таким образом, нельзя закодировать буквы: И, Щ, Ь, Ы, Э.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит число. Если число двузначное, то нужно найти сумму цифр в числе. Если число трехзначное – произвести произведение цифр числа. Если число четырехзначное – найти среднее арифметическое цифр этого числа. Если число иное – вывести запись «Введите 2-х, 3-х или 4-х значное число».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Андрей-Викторовна1910
Aleksei368
rukodelnizza1
dearmaria
Анна егорович526
Daulyatyanov1266
bondarenkoss
olarina6510
cleopatra1959
vovkiv7864
Юрий197
gostivdom302
mototeh69
Stefanidi_Semeikina1896
kv135549
▲